Knitting Chart Editor User Manual

This manual describes version 2.4.0 of the Knitting Chart Editor
Copyright © 2013, 2014 StitchMastery

Feedback

To report a bug or make a suggestion regarding the Knitting Chart Editor or this manual please email StitchMastery at support@stitchmastery.com
# Table of Contents

1. Getting Started .................................................................................................................. 1
   Knitting Chart Editor Overview ........................................................................................... 1
   Installing StitchMastery Knitting Chart Editor ................................................................. 2
      Windows (XP, Vista, 7, 8, 9 and 10) ............................................................................... 2
      Mac OS X (Snow Leopard 10.6, Lion 10.7, Mountain Lion 10.8, Mavericks 10.9,
      Yosemite 10.10 and El Capitan 10.11) ........................................................................... 6
      Linux (tested and officially supported on Ubuntu only) ............................................... 8
   Uninstalling StitchMastery Knitting Chart Editor ............................................................. 8
      Windows .......................................................................................................................... 8
      Mac OS X ....................................................................................................................... 9
      Linux .............................................................................................................................. 9
   Running StitchMastery Knitting Chart Editor ................................................................. 9
      Windows .......................................................................................................................... 9
      Mac OS X ....................................................................................................................... 9
      Linux .............................................................................................................................. 9
      Workspace location ......................................................................................................... 9
   Activating Knitting Chart Editor ...................................................................................... 10
   End User Licence Agreement ............................................................................................. 11
   Creating a New Chart Diagram ......................................................................................... 11
   Opening, Saving and Closing Chart Diagrams ................................................................. 14

2. Chart Editing ...................................................................................................................... 16
   Editing Tools ....................................................................................................................... 16
      Selection Tools ............................................................................................................... 16
      Drawing Stitches ............................................................................................................. 20
      Colouring Stitches ......................................................................................................... 21
      Zooming and Panning Chart Diagrams ......................................................................... 21
      Fill Mode ....................................................................................................................... 22
      Stitch 'delete' with Right Mouse Button ...................................................................... 22
   Copying and Pasting Chart Elements .............................................................................. 23
      Copy and Paste Commands. .......................................................................................... 23
      Invoking the Copy Command. ....................................................................................... 23
      Invoking the Paste Command. ..................................................................................... 24
   Copy Dragging ................................................................................................................... 24
   Copying Columns that contain Wide Stitches ................................................................... 24
   Moving Charts, the Key and Chart Elements .................................................................. 24
      Moving Charts and the Key ............................................................................................ 25
      Moving Rows, Columns and Stitches ............................................................................ 24
   Inserting and Deleting Rows and Columns ..................................................................... 25
      Inserting Rows ............................................................................................................... 25
      Inserting Copied Rows ................................................................................................. 25
      Deleting Rows ............................................................................................................... 26
      Deleting Columns .......................................................................................................... 26
      Inserting Copied Columns ............................................................................................ 26
      Deleting Columns .......................................................................................................... 27
   Editing Chart Properties ................................................................................................ 27
      Editing Diagram Properties. ........................................................................................ 28
   Working with the Chart Diagram Key .............................................................................. 30
      Editing Key Properties ................................................................................................ 30
      Editing Key entries ....................................................................................................... 31
      Deleting Key Entries .................................................................................................... 32
      Hiding Key Entries ....................................................................................................... 32
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>5. What's a namespace?</td>
<td>90</td>
</tr>
<tr>
<td>What's a namespace?</td>
<td>90</td>
</tr>
<tr>
<td>6. Repeats and Borders</td>
<td>91</td>
</tr>
<tr>
<td>Repeats and Borders</td>
<td>91</td>
</tr>
<tr>
<td>Differences between Repeats and Borders</td>
<td>91</td>
</tr>
<tr>
<td>3. Working with the Stitch Library</td>
<td>45</td>
</tr>
<tr>
<td>About Stitch Libraries</td>
<td>45</td>
</tr>
<tr>
<td>Version 1 files</td>
<td>45</td>
</tr>
<tr>
<td>Version 2 files</td>
<td>45</td>
</tr>
<tr>
<td>Opening Version 1 files in Version 2</td>
<td>46</td>
</tr>
<tr>
<td>Stitchmastery Libraries</td>
<td>47</td>
</tr>
<tr>
<td>User Stitch Libraries</td>
<td>48</td>
</tr>
<tr>
<td>Viewing and editing stitch libraries</td>
<td>50</td>
</tr>
<tr>
<td>Viewing and editing stitch libraries via Preferences</td>
<td>50</td>
</tr>
<tr>
<td>Setting a stitch library as the 'active' stitch library</td>
<td>63</td>
</tr>
<tr>
<td>Editing a user stitch library via the Palette</td>
<td>63</td>
</tr>
<tr>
<td>4. Working with Stylesheets</td>
<td>65</td>
</tr>
<tr>
<td>About Stylesheets</td>
<td>65</td>
</tr>
<tr>
<td>Making changes with stylesheets</td>
<td>67</td>
</tr>
<tr>
<td>Viewing and editing stylesheets</td>
<td>70</td>
</tr>
<tr>
<td>Viewing a Stitchmastery stylesheet</td>
<td>71</td>
</tr>
<tr>
<td>Creating a user stylesheet</td>
<td>72</td>
</tr>
<tr>
<td>Setting a stylesheet as the 'active' stylesheet</td>
<td>73</td>
</tr>
<tr>
<td>Editing a user Appearance stylesheet</td>
<td>73</td>
</tr>
<tr>
<td>Editing a user Written stylesheet</td>
<td>75</td>
</tr>
<tr>
<td>Editing a user Text Templates stylesheet</td>
<td>76</td>
</tr>
<tr>
<td>Removing a user stylesheet</td>
<td>79</td>
</tr>
<tr>
<td>Exporting user stylesheets</td>
<td>79</td>
</tr>
<tr>
<td>Importing user stylesheets</td>
<td>80</td>
</tr>
<tr>
<td>Text Templates</td>
<td>82</td>
</tr>
<tr>
<td>Template Control Words</td>
<td>82</td>
</tr>
<tr>
<td>Template Details</td>
<td>83</td>
</tr>
<tr>
<td>2. Working with stylesheets</td>
<td>67</td>
</tr>
<tr>
<td>Viewing and editing stitch libraries</td>
<td>63</td>
</tr>
<tr>
<td>Viewing and editing stitch libraries via Preferences</td>
<td>63</td>
</tr>
<tr>
<td>Setting a stitch library as the 'active' stitch library</td>
<td>63</td>
</tr>
<tr>
<td>Editing a user stitch library via the Palette</td>
<td>63</td>
</tr>
<tr>
<td>4. Working with Stylesheets</td>
<td>65</td>
</tr>
<tr>
<td>About Stylesheets</td>
<td>65</td>
</tr>
<tr>
<td>Making changes with stylesheets</td>
<td>67</td>
</tr>
<tr>
<td>Viewing and editing stylesheets</td>
<td>70</td>
</tr>
<tr>
<td>Viewing a Stitchmastery stylesheet</td>
<td>71</td>
</tr>
<tr>
<td>Creating a user stylesheet</td>
<td>72</td>
</tr>
<tr>
<td>Setting a stylesheet as the 'active' stylesheet</td>
<td>73</td>
</tr>
<tr>
<td>Editing a user Appearance stylesheet</td>
<td>73</td>
</tr>
<tr>
<td>Editing a user Written stylesheet</td>
<td>75</td>
</tr>
<tr>
<td>Editing a user Text Templates stylesheet</td>
<td>76</td>
</tr>
<tr>
<td>Removing a user stylesheet</td>
<td>79</td>
</tr>
<tr>
<td>Exporting user stylesheets</td>
<td>79</td>
</tr>
<tr>
<td>Importing user stylesheets</td>
<td>80</td>
</tr>
<tr>
<td>Text Templates</td>
<td>82</td>
</tr>
<tr>
<td>Template Control Words</td>
<td>82</td>
</tr>
<tr>
<td>Template Details</td>
<td>83</td>
</tr>
</tbody>
</table>
List of Tables

1.1. System Requirements for 32 bit Windows ................................................................. 2
1.2. System Requirements for 64 bit Windows ................................................................. 2
1.3. System Requirements for Mac OS X ............................................................................ 6
1.4. System Requirements for 32 bit Linux ...................................................................... 8
1.5. System Requirements for 64 bit Linux ...................................................................... 8
4.1. Key Text ...................................................................................................................... 83
4.2. Row Labels .................................................................................................................. 84
4.3. Repeats ....................................................................................................................... 85
4.4. Row Contents .............................................................................................................. 86
4.5. Stitch Count ................................................................................................................ 89
4.6. Row Format ................................................................................................................ 89
Chapter 1. Getting Started

Knitting Chart Editor Overview

Charts created using the StitchMastery Knitting Chart Editor are stored in a file called the Chart Diagram file. Chart Diagram files have a .knt2 file extension.

The picture below shows the main areas of the Knitting Chart Editor software visible when a Chart diagram file is opened with the Knitting Chart Editor.

These are:-

- The main Menu that is at the top of the Window. Note that the position of the Menu varies slightly between Windows, Mac OS and Linux versions. The picture above is from a Mac OS system.

- The main Toolbar sits below the Menu and contains Icons giving quick access to many features.

- The Drawing Area where the Charts and Key can be edited using the drawing and painting tools and other commands. Each Chart Diagram file initially contains one chart but more can be added.

- The palette contains a palette toolbar with selection and zoom tools as well as drawers containing stitch and colour definitions.

- The Output Text view shows the written instructions in a format that is 'knitter friendly'. For example, if there are 'no stitch' areas on the chart, the 'no stitches' will be not be shown in the output written instructions.

- The Outline View displays either an Overview or an expandable Outline. Icons on the Outline View toolbar enable toggling between the Overview and the Outline.

The picture above shows the Overview visible. The Overview displays the complete Drawing Area and is particularly useful when the Drawing Area is too large to be visible at the chosen zoom level. A pale blue rectangle shows the visible area of the rectangle. The blue rectangle can be dragged to change the visible area of the Drawing Area.

The expandable Outline shows in detail the stitches contained in each row of each chart. If the Knitting Chart Editor has found an error on a chart then this is highlighted in the Outline. See Validating charts for more details.
• The Status line is at the very bottom of the Window. This displays the current row and column location of the mouse. This is particularly useful when the row and column numbers are not in the visible part of the Drawing Area.

Note that there will be a Drawing Area for each Chart Diagram file that is currently open. In contrast, there is only one each of the Output Text and Outline Views whose contents change depending on the currently active Drawing Area.

Installing StitchMastery Knitting Chart Editor

StitchMastery Knitting Chart Editor is available for the following operating systems: Windows (XP, Vista, 7, 9 and 10), Mac OS X (Snow Leopard 10.6, Lion 10.7, Mountain Lion 10.8, Mavericks 10.9, Yosemite 10.10 and El Capitan 10.11), Linux (tested and officially supported on Ubuntu only).

Note that on Mac OS X, Stitchmastery will only run on machines that have a 64 bit processor. For Windows and Linux, Stitchmastery will run on both 32 bit and 64 bit machines.

Note that the demo and full versions of the software are the same. The software runs in demo mode until activated. Note that, if you have already installed the demo version, there is no need to download and install again. You just need to enter an activation key. See Activating Knitting Chart Editor.

Download the Stitchmastery software from:-

http://www.stitchmastery.com/downloads

Windows (XP, Vista, 7, 8, 9 and 10)

Both 32 bit and 64 bit versions of Knitting Chart Editor are available for Windows. Please download the appropriate version for your system.

Table 1.1. System Requirements for 32 bit Windows

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disk Space:</td>
<td>100 MB</td>
</tr>
<tr>
<td>Memory:</td>
<td>1 GB</td>
</tr>
<tr>
<td>Java:</td>
<td>32 bit version of Java 7.0 or higher</td>
</tr>
<tr>
<td>Processor:</td>
<td>32 bit</td>
</tr>
</tbody>
</table>

Table 1.2. System Requirements for 64 bit Windows

<table>
<thead>
<tr>
<th>Requirement</th>
<th>Version</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disk Space:</td>
<td>100 MB</td>
</tr>
<tr>
<td>Memory:</td>
<td>1 GB</td>
</tr>
<tr>
<td>Java:</td>
<td>64 bit version of Java 7.0 or higher</td>
</tr>
<tr>
<td>Processor:</td>
<td>64 bit</td>
</tr>
</tbody>
</table>

Download the Stitchmastery Windows installer from:-

http://www.stitchmastery.com/downloads

choosing the appropriate file for your system. You will see a dialog similar to the one below asking you what you want to do with the downloaded file. The exact look and wording of this dialog will depend on your browser. Be sure to select the Save file option.
After downloading you should have a file called either stitchmastery-?-windows-x86.zip or stitchmastery-?-windows.zip where the ? represents the version of the software. The file is a Windows installer and should have an .exe file extension.

1. Double click on the file to open the installation dialog that will guide you through the install.

2. If you double click on the file and you see a dialog similar to the one below this is because the browser has removed the .exe file extension. This means that Windows does not properly recognise the file as an installer.

The solution is to rename the file so that it does have a .exe file extension. See Renaming a file to add a file extension.

3. On Windows Vista and Windows 7, 8, 9 and 10 systems, the Windows User Account Control feature will ask 'Do you want the following program to make changes to this computer?' Reply Yes.

4. It is recommended that you close all other applications before starting the install.
5. The installer will display the End User License Agreement for the software. You must accept all the terms of the agreement in order to install Knitting Chart Editor. Selecting 'I Agree' allows the installation to continue.

6. Select where you would like Knitting Chart Editor to be installed. The default is the Documents folder but you can change this by selecting Browse and choosing another folder. It is recommended that you do NOT install to the Program Files folder as this can cause problems with updating the software at a later date.

7. The installer now copies files to the installation location. Once completed select Close to close the install dialog.

An entry for the Knitting Chart Editor has been added to the Start > All Programs menu and can be used to launch Knitting Chart Editor.
Renaming a file to add a file extension (Windows XP, Vista and 7)

1. Right click on the file and select rename.

2. Add .exe to the end of the file name.

3. Windows will prompt you to ask if you are sure that you want to change the file extension.

   Select Yes.

Renaming a file to add a file extension (Windows 8, 9 and 10)

On Windows 8/9/10 the file extensions are hidden by default. You will be able to recognise whether a file is missing a file extension by looking at the file type:

If a file has no file extension then the file type will be listed as 'File', whereas those with an .exe file extension will be shown as 'Application'.

1. In order to edit the file extension you first need to make it visible. To do this select View > File name extension:
2. Then either right click on the file name or select the file and then click on the file name to get an 'edit box'.

3. Windows will prompt you to ask if you are sure that you want to change the file extension. Select Yes.

4. Afterwards the file type should be displayed as 'Application';-

5. Do not forget to use View > File name extension to hide the file extensions again. File extensions are hidden so that accidental editing of them is much harder.

Mac OS X (Snow Leopard 10.6, Lion 10.7, Mountain Lion 10.8, Mavericks 10.9, Yosemite 10.10 and El Capitan 10.11)

Note that only machines with 64 processors can run Knitting Chart Editor.

To find out if your Mac OS X has a 64 bit processor follow the instructions at;-

https://support.apple.com/en-gb/HT201948

Table 1.3. System Requirements for Mac OS X

Disk Space: 100 MB
Memory: 1 GB
Java: 64 bit version of Java 7.0 or higher
Processor: 64 bit Intel

After downloading you should have a file called Stitchmastery_?.dmg where the ? represents the version of the software. The file is a Mac OS X image for the StitchMastery Knitting Chart Editor.

1. Once the download is complete, your system should automatically mount the file as a temporary disk.

2. As the disk is mounted, you will be prompted to agree to the End User License Agreement. Click Agree to continue.

3. Once the disk is mounted, use the Finder application to view it. Drag the StitchMastery folder from the disk to the Applications folder.
Linux (tested and officially supported on Ubuntu only)

Both 32 bit and 64 bit versions of Knitting Chart Editor are available for Linux systems.

Due to the large variety of Linux distributions, official support for the Knitting Chart Editor is only provided for Ubuntu although I will do my best to help with issues on other Linux distributions.

To double check if the StitchMastery Knitting Chart Editor is compatible with your system, please download and install the demo version of the software.

Table 1.4. System Requirements for 32 bit Linux

<table>
<thead>
<tr>
<th>Requirement</th>
<th>32 bit Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disk Space:</td>
<td>100 MB</td>
</tr>
<tr>
<td>Memory:</td>
<td>1 GB</td>
</tr>
<tr>
<td>Java:</td>
<td>32 bit version of Java 7.0 or higher</td>
</tr>
<tr>
<td>Processor:</td>
<td>Intel</td>
</tr>
</tbody>
</table>

Table 1.5. System Requirements for 64 bit Linux

<table>
<thead>
<tr>
<th>Requirement</th>
<th>64 bit Linux</th>
</tr>
</thead>
<tbody>
<tr>
<td>Disk Space:</td>
<td>100 MB</td>
</tr>
<tr>
<td>Memory:</td>
<td>1 GB</td>
</tr>
<tr>
<td>Java:</td>
<td>64 bit version of Java 7.0 or higher</td>
</tr>
<tr>
<td>Processor:</td>
<td>Intel</td>
</tr>
</tbody>
</table>

After downloading you should have a file called either stitchmastery-?-linux.gtk-x86.zip or stitchmastery-?-linux.gtk-x86_64.zip where the ? represents the version of the software. The file is a zip file of the StitchMastery Knitting Chart Editor.

1. Once the download is complete, use Archive Manager to open the zip file and extract its contents to your chosen location.

Uninstalling StitchMastery Knitting Chart Editor

Windows

Select **Start > All Programs** and find the shortcut folder where the Knitting Chart Editor short cut icon was created during the install process. By default this is called StitchMastery.
Select Uninstall Knitting Chart Editor. The uninstaller for Knitting Chart Editor runs.

When the uninstallation has completed, select Close to close the uninstall dialog.

**Mac OS X**

Drag the StitchMastery folder from the Applications folder to the trash.

**Linux**

Delete the StitchMastery installation folder with all of its contents.

**Running StitchMastery Knitting Chart Editor**

To launch the application:

**Windows**

Select Start > All Programs and find the shortcut folder where the Knitting Chart Editor short cut icon was created during the install process. By default this is called StitchMastery.

Select Knitting Chart Editor.

**Mac OS X**

Double click on the StitchMastery app in your Applications folder.

**Linux**

Open the StitchMastery folder. Double click on knittingChartEditor.

**Workspace location**

The splash screen will appear while the application is being launched.

After that, the Workspace Selection dialog will be displayed so that you can select where the workspace folder will be located. The workspace is the folder where Knitting Chart Editor stores your preferences and important settings.
For all versions prior to 1.7.0, this location was always a folder called smworkspace at the 'user.home' location for your machine. On Windows the 'user.home' location is typically \users\userid where userid is the logon for your machine but this can vary. On Mac the 'user.home' location is typically /users/userid and on Linux /home/userid where userid is again the logon for your machine. If you have run Knitting Chart Editor at a version before 1.7.0 and made a lot of changes to the preferences you may wish to continue using the smworkspace in your 'user.home' location.

If you do not wish to see this dialog every time that you start Knitting Chart Editor, check 'Use this as the default and do not ask again'. If you decide that you would like to change the location of the workspace file, you can get back to this dialog at any time, by selecting Tools > Switch Workspace from the main menu.

Select OK to continue.

If prompted about creating a new directory, select OK.

Activating Knitting Chart Editor

If you are running Knitting Chart Editor for the first time or you are running the demo version, the Activate StitchMastery Knitting Chart Editor dialog will appear.

If you wish to continue running Knitting Chart Editor as the demo version, select Continue. The Knitting Chart Editor will open ready for you to create and edit charts. In demo mode, certain features will be restricted or disabled. These are:-

• Charts will be restricted to 12 rows and 12 columns.
• The Export to Image feature that creates image files of the charts and key is disabled.

• The Export to Text feature that create text files with the written instructions for each chart is disabled.

If you have purchased Knitting ChartEditor, you should have received an email containing an activation key.

Enter this activation key into the text box in the Activate StitchMastery Knitting Chart Editor dialog and select Activate.

Knitting Chart Editor contacts the StitchMastery website and sends it the activation key as well as a unique identifier for your machine. The website then creates a license file that is unique to your machine and sends it back to the Knitting Chart Editor.

The Knitting Chart Editor saves this license file on your machine which acts as evidence that the activation has been successful. Every time that the Knitting Chart Editor starts it looks for the license file. If it finds it, it runs in 'full' mode, otherwise it runs in demo mode.

Note that each license file is specific to the machine and hard disk drive that it was created for. Moving a license file to a different machine or hard drive for example, after a hard drive has been replaced or as a result of a computer upgrade, will mean that the license file is no longer valid.

If there are any problems activating the software, please contact support@stitchmastery.com for help. If there is an error message or code, please include that information in the email.

**End User Licence Agreement**

The End User Licence Agreement for the StitchMastery Knitting Chart Editor allows you to install and use the software on two computers. These can be different operating systems. Hence the supplied activation key is valid for two activations. If you replace a computer and need another activation, then please contact support@stitchmastery.com for an additional activation.

A copy of the End User Licence Agreement is supplied as a text file called licence.rtf with the software and can be found in the KnittingChartEditor folder. It can also be viewed on the StitchMastery website at www.stitchmastery.com/knitting-chart-editor-licence

**Creating a New Chart Diagram**

To create a new Chart Diagram file:-

1. On the main menu bar, select **File > New > New Chart Diagram**.

   Alternatively in the main toolbar, select the New Chart Diagram button.

The New Chart Diagram dialog opens.
2. The **Folder** defaults to the home directory. To select a different directory use the Browse button.

3. The **File Name** contains a generated default name. If desired, type in a different file name. The file extension must be ".knit".

4. Check that the **Chart Properties** tab is selected.

5. (Optional) Type in a **Chart title**. This can be edited later.

6. (Optional) Change the **Number of rows** and **Number of columns** that the chart will be initialized with, as well as the starting row and column numbers. These can be changed later.

7. (Optional) Select the positioning of **Column numbers**. Note that individual column numbers can be either hidden or edited later.

8. (Optional) Select if the chart represents **Circular**, **Flat** or **Mosaic** knitting. Again, this can be changed later.

Charts for flat knitting always alternate right side (RS) and wrong side (WS) rows. Charts for circular knitting have only RS rows. Charts for mosaic knitting alternate two RS rows with two WS rows. RS rows have the row number at the right hand side of the chart, whilst those of WS rows are on the left hand side.

An alternate form of chart for mosaic knitting that has a row number at both ends is not yet supported by StitchMastery but will be added in a future version.

9. (Optional) Select if the chart should start with a RS or WS row. This option is only enabled for flat or mosaic knitting.

10. (Optional) Select if the WS rows should be hidden. This option is only enabled for flat knitting. Support to hide rows for other chart forms will be added in a future version.
11. Select the **Diagram Properties** tab. This tab allows for selecting the stitch library and stylesheets associated with this chart diagram file. For more information about stitch libraries see Stitchmastery Libraries. To find out more about stylesheets see About Stylesheets. If no user stitch libraries or stylesheets have been created yet then only the Stitchmastery ones will be listed. It will be possible to change the stitch library and stylesheets at a later point.

![Diagram Properties](image)

12. (Optional) **Appearance**: A list of all of the appearance stylesheets known to Stitchmastery is displayed and can be selected from.

13. The values for grid, grid highlighting, annotating repeated stitches and symbol contrast are initialised from the selected appearance stylesheet. They can all be individually edited to override the values from the stylesheet. Press **Apply** to reset the grid, grid highlighting, annotating repeated stitches and symbol contrast values from the stylesheet.

14. (Optional) **Grid**: to view or edit the grid values click either on the right pointing triangle or on **More on grid** ... to expand the Grid display. Once expanded, click either on the down pointing triangle or on **Less on grid** ... to collapse the Grid display.

   Enter the width and height of each cell in the chart as well as choosing the colour of the grid lines.

15. (Optional) **Grid highlighting**: to view or edit the grid highlighting values click either on the right pointing triangle or on **More on grid highlighting** ... to expand the Grid highlighting display. Once expanded, click either on the down pointing triangle or on **Less on grid highlighting**... to collapse the Grid highlighting display.

   Enter the number of rows/columns between highlighting lines as well as choosing the colour of the highlight.

16. (Optional) **Annotating repeated stitches**: to view or edit the annotation values click either on the right pointing triangle or on **More on annotating** ... to expand the Annotations display. Once expanded, click either on the down pointing triangle or on **Less on annotations** ... to collapse the Annotations display.
In order to show annotations and be able to edit the annotations values, select **Display Annotations**.

The **Minimum number of stitches** defines the number of similar stitches that must be next to each other before an annotation is displayed. Any ‘stretch’ less than this number is not annotated. This number must be between 3 and 9.

Select **Number background transparent** to have the number drawn with a transparent background. If not selected, the number is drawn with a white background. A transparent background is useful for a colourwork chart, whilst a white background is best if the number is in front of symbols and grid lines.

If **Automatically contrasts with yarn/colour** is selected then, if the background colour is dark the number colour swaps to white. Note that this only works if **Include colour in written instructions** is also selected.

The font for the numbers can be selected.

There are four options for the horizontal positioning of the annotation number within the stretch of repeated stitches: **Left**, **Right** and **Centre** position in the number to the left, right or centre of the stretch respectively. **Beginning** places the number at the beginning of the stretch. That is, for right side rows and for charts worked in the round, the number is always on the right hand side, whilst it is on the left for wrong side rows.

The vertical position can be set to either **Top**, **Bottom** or **Middle**.

Once the number's horizontal and vertical positions have been set, its exact location can be fine tuned by editing the **Gap at sides** and **Gap at top/bottom** values. However, these values have no effect if the number is centred.

17. (Optional) If **Stitch symbol colour automatically contrasts with background colour** is selected then, if the background colour is dark, the symbol colour swaps to white.

18. (Optional) Select the **Default stitch type** to be used when creating a chart or adding rows or columns. Available choices are knit, purl and two variants of 'no stitch'.

19. (Optional) **Written Instructions**: A list of all of the Written stylesheets known to Stitchmastery is displayed and can be selected from.

20. (Optional) **Include colour in written instructions**: If selected then colour is included in the written instructions in the Outline Text view and in the output from Export to View.

21. (Optional) **Stitch library**: A list of all of the stitch libraries known to Stitchmastery is displayed and can be selected from.

22. (Optional) **Text Templates**: A list of all of the Text Template stylesheets known to Stitchmastery is displayed and can be selected from.

23. Select **Finish**. The dialog closes and the chart diagram file is created and opened for editing.

The New Chart Diagram dialog can also be opened using the keystroke **Control+N** (on Windows) or **Cmd+N** (on Mac).

---

**Opening, Saving and Closing Chart Diagrams**

To open an existing Chart Diagram file:-

1. On the main menu bar, select **File > Open**. The Open dialog opens.
2. Navigate to the desired file. Only files that have been created with the StitchMastery Knitting Chart Editor and have a ".knit" file extension can be opened.

3. Select **Open**.

The Open dialog can also be opened using the keystroke **Control+O** (on Windows) or **Cmd+O** (on Mac) or by selecting the Open Icon from the toolbar.

The Knitting Chart Editor maintains a list of recently opened files that provides a shortcut when opening. To view the list select **File** from the main menu bar. The list is located towards the bottom of the drop down menu. Selecting a file opens it.

To save a Chart Diagram file:-

1. **Note:** This is only valid if files have unsaved edits.

2. On the main menu bar, select either **File > Save** (to save the currently active file) or **File > Save All** (to save all files with unsaved edits).

   Alternatively use the keystrokes **Control+S** / **Control+Shift+S** (on Windows) or **Cmd+S** / **Cmd+Shift+S** (on Mac) or select the Save / Save All Icons from the toolbar.

To save a Chart Diagram file as a duplicate:-

1. On the main menu bar, select **File > Save As**. The Save As dialog opens.

2. The file name contains a generated default name. If desired, type in a different file name. The file extension must be ".knit".

3. Select **OK**.

   Alternatively select the Save As Icon from the toolbar.

To close a Chart Diagram file:-

1. On the main menu bar, select **File > Close** (to close the currently active file) or **File > Close All** (to close all open files).

2. If any files have unsaved edits you will be prompted to either cancel the close or to save edits.

   Alternatively use the keystrokes **Control+W** / **Control+Shift+W** (on Windows) or **Cmd+W** / **Cmd+Shift+W** (on Mac).
Chapter 2. Chart Editing

Editing Tools

Selection Tools

There are two selection tools in the Knitting Chart Editor; the Arrow Selection Tool and the Marquee Selection Tool.

Arrow Selection Tool

Select the Arrow Selection Icon from the main tool bar or from the palette tool bar. The cursor changes to an arrow.

To select an item with the Arrow Selection Tool click within the bounds of the item. If an item contains other items then you must click within the bounds of the item but not on its contained items. This applies to the key, rows, columns and charts with specific examples given below.

Key Entry Selection

The key contains entries for stitch types, yarns (colours) and borders.

These entries consist of a square box and a label.

To select a stitch type, yarn or border select on the square box as shown in the image. Selection enables the entry to be moved within the key and enables relevant menu items.

The label can also be selected in order to edit its text.
Key Selection

The image shows the bounds of the key and the key entries and indicates the best location to click in order to select the key.

Alternatively select any of the key entries and then use the keystroke Alt+Up Arrow to select the parent of the selected item. Another option is to use the Marquee Selection Tool.

Row Selection

Rows can be selected by clicking at either end of the column as indicated.

Column Selection

Columns can be selected by clicking at either end of the column as indicated.
If a column contains a stitch that spans more than one column, such as a cable stitch, then all columns that include that stitch must be selected before copy, cut, delete and paste commands are enabled.

**Stitch Selection**

Stitches can be selected by clicking anywhere on their cell.

**Repeat Selection**

Repeats are not directly selectable as there is no visible part on a chart. However they can be selected indirectly by first selecting any of the stitches that are contained by the repeat. Then use the keystroke **Alt+Up Arrow** to select the parent of the selected stitch. This will be the repeat and the selection rectangle will change from that of the stitch to that of the repeat.

**Chart Selection**

Charts can be selected by clicking in any of the four corners as indicated.
Chart Title Selection

If the chart has a title then the label can be selected in order to move it or edit its location.

Selecting a Range

A range of rows, columns and stitches can be selected by using the Shift key to modify the selection. For example to select all rows between row 1 and row 6, first select row 1. Then hold down the Shift key and select row 6. The selection of a range of columns or a block of stitches works in a similar way.

Toggling Selection

The Control (Windows) or Cmd (Mac) can be used to toggle selection. By holding down the Control (Windows) or Cmd (Mac) key whilst clicking on an item, any selected item will be deselected, whilst unselected items will be selected.

Selection with the Arrow Keys

Once an item has been selected, the selection can be changed by using the arrow keys. This is particularly useful when selecting rows, columns or stitches within a chart.

Moving a Selection

Once an item has been selected, the selection can be moved to the next stitch, row or column by using any of the four arrow keys (up, down, left, right).

Adding to a Selection

Once an item has been selected, additional items can be selected by holding down the Shift key whilst using any of the four arrow keys (up, down, left, right).

Selecting the Parent or Container of a Selection

Once an item has been selected, its parent or container item can be selected by holding down the Alt key whilst using the Up Arrow key.
Chart Editing

Marquee Selection Tool

Select the Marquee Selection Icon from the main tool bar or from the palette tool bar. The cursor changes to 'cross hairs'.

To select an item / items with the Marquee Selection Tool click down on the canvas and then, whilst the button is still down, move the mouse to draw a rectangle. Release the mouse button to finish drawing the rectangle. All items which are completely within the bounds of the rectangle will be selected.

Other Selections

The Selection menu on the toolbar has a number of 'specialised' selections. These are:-

• Select All Charts
• Select Key
• Select Alternate Rows starting at First

This is very useful if wanting to lightly shade alternate rows using the 'Fill' tool as a way of making large charts more legible.

The rows that are selected can be filtered by selecting a chart first. For example, if there are several charts in a chart file and you wish to only select alternate rows in one of the charts, first select that chart and then select Select Alternate Rows starting at First. Only alternate rows in the selected chart will become selected.

• Select Alternate Rows starting at First

As for the selection above but the selected rows will start with the second row in the chart rather than the first.

• Select All Repeats

If any repeats have been added to the chart(s) then all of those repeats will be selected.

• Select All Repeats in Selection

This selection is to filter the selection of repeats. For example, if a chart is first selected and then Select All Repeats in Selection chosen, then only the repeats in the selected chart will become selected.

The filtering also works by selecting a row or several rows. Only repeats in the selected row(s) will become selected.

• Select Containing Repeat(s) of Selected Stitches/Repeats

If a stitch is selected then, if that stitch is contained within a repeat, choosing Select Containing Repeat(s) of Selected Stitches/Repeats will cause that repeat to become selected. This also works for repeats that are themseleves contained within a repeat and for multiple stitches and repeats.

Drawing Stitches

Stitches can be drawn on the chart whilst in Drawing Mode. In Drawing Mode two different tools are active; the Drawing Tool and the Arrow Selection Tool.
Whilst the mouse is over stitches in a chart then the Drawing Tool is active, otherwise the Arrow Selection Tool is active.

To enter Drawing Mode, select a stitch type from the palette or from the key in the Chart Diagram file. Initially the cursor will be an arrow as the Arrow Selection Tool is active. If the mouse is moved over stitches in the chart the Drawing Tool will become active and the cursor will change to a pencil.

If drawing the stitch is not possible then the cursor changes to a 'Not Allowed' image. An example of this is when a wide stitch such as a cable is selected but the mouse is near the right hand side of the chart.

**Using the Drawing Tool.**

1. To draw a stitch on the chart move the mouse to the desired location and click. A single stitch will be drawn.

2. To draw several stitches adjacent to one another, click down on the first stitch and then, whilst the button is still down, move the mouse over as many stitches as desired. Release the mouse button to finish drawing.

3. If the stitch type has not been used in the chart before, then an entry for the new stitch type will be automatically added to the key.

4. To change to a different stitch type or to a colour / yarn, select again from the palette or from the key.

**Colouring Stitches**

Colours can be drawn on the chart whilst in Painting Mode. In Painting Mode two different tools are active; the Painting Tool and the Arrow Selection Tool.

Whilst the mouse is over stitches in a chart then the Painting Tool is active, otherwise the Arrow Selection Tool is active.

To enter Painting Mode, select a colour / yarn from the palette or from the key in the Chart Diagram file. Initially the cursor will be an arrow as the Arrow Selection Tool is active. If the mouse is moved over stitches in the chart the Painting Tool will become active and the cursor will change to a paintbrush.

**Using the Painting Tool.**

1. To colour a stitch on the chart move the mouse to the desired location and click. A single stitch will be coloured.

2. To colour several stitches adjacent to one another, click down on the first stitch and then, whilst the button is still down, move the mouse over as many stitches as desired. Release the mouse button to finish painting.

3. If the colour has not been used in the chart before, then an entry for the new colour will be automatically added to the key.

4. To change to a different stitch type or to a colour / yarn, select again from the palette or from the key.

**Zooming and Panning Chart Diagrams**

**Zooming**

To change the zoom level of a Chart Diagram file either use the drop-down zoom selection on the main tool bar or select the Zoom-In and Zoom-Out tool from the palette tool bar.
Panning / Scrolling

If the current zoom level is such that the Chart Diagram file is not fully visible within the canvas, then scroll bars will automatically be added.

To pan or scroll the canvas to change the portion of the Chart Diagram file that is visible several possibilities exist:-

1. Use the scroll bars on the side of the canvas.
2. Select the Outline View. This shows an overview of the Chart Diagram file. If the Chart Diagram file is larger than the canvas then the Outline View also shows a pale blue rectangle representing the canvas. Moving this blue rectangle in the Outline View by dragging it with the mouse scrolls the Chart Diagram file in the canvas itself.
3. When the Arrow Selection Tool is active, hold down the space bar and use mouse dragging to scroll the Chart Diagram file.
4. During certain operations that involve mouse dragging automatic scrolling is in effect. These operations include moving the chart and key, 'copy dragging' stitches, rows and columns and selecting with the Marquee Selection Tool.

Fill Mode

When Fill Mode is active, an area of a chart or even a complete chart can be selected and then 'filled' with a yarn or stitch.

Fill Mode can be toggled on and off by selecting the Activate Fill Mode / Deactivate Fill Mode icon from the toolbar.

Using the Fill Mode.

1. Activate the Fill Mode by selecting the Activate Fill Mode icon from the toolbar.
2. Select either a chart, one or more rows or a group of stitches.
3. Select a stitch or colour/ yarn from either the key in the chart diagram file or from the palette. The selected area will be filled with the selected stitch / colour / yarn.
4. The Fill Mode does not work for column selections. To use the Fill Mode to fill a column, make a stitch selection by selecting the topmost stitch in the column, holding down the Shift key and then selecting the bottommost stitch in the column.
5. If a 'no stitch' is hidden then this is not affected by the Fill Mode. To use the Fill Mode to edit a hidden 'no stitch' first unhide the hidden stitches by selecting either the chart or row(s) and selecting Edit > Show Hidden Items in Selection from the main menu.

Stitch 'delete' with Right Mouse Button

All of the editing operations are performed using the left mouse button. This is equivalent to the single mouse button if using a one button mouse. When a right mouse button is available, this can optionally be set as a shortcut button to delete a stitch.

Initially the Right Mouse Button stitch delete feature is not enabled but can be either enabled or disabled through user preference. Select Tools > Preferences > Knitting Chart Editor to open the relevant preference page. Then check Enable stitch delete with right mouse click as desired.
Once the Right Mouse Button stitch delete feature is enabled and either the Arrow Selection Tool or the Drawing or Painting Tools are active, then a right mouse click will cause the stitch directly under the cursor to be 'deleted'. A stitch is not actually ‘deleted’ but is reset to the default stitch which is a knit stitch in the default yarn.

This is equivalent to selecting a stitch and then ‘deleting’ the stitch using the Delete icon from the toolbar or the delete or backspace keys.

**Copying and Pasting Chart Elements**

To copy and paste rows, columns or stitches two possibilities exist; the Copy and Paste Commands and Copy Dragging. Charts can also be copied but only by using the Copy and Paste Commands.

**Copy and Paste Commands.**

The process of using the Copy and Paste Commands is as follows:-

1. Select the items to be copied (see Selection Tools). Selected items should be of the same type, for example only rows or only columns or only stitches but not a mixture of these.

   The selection should not contain hidden 'no stitches' as this will cause strange results. To copy and paste areas of a chart containing hidden 'no stitches' first unhide the hidden stitches by selecting either the chart or row(s) and selecting Edit > Show Hidden Items in Selection from the main menu.

2. Invoke the Copy Command to copy the selected items to the System Clipboard. Calling the Copy command erases the existing contents of the Clipboard.

3. Make a selection on the chart to indicate where the paste will occur. The selection should be of the same type as the items that were copied, i.e. select a row in order to paste copied rows. The selection marks the top left-most corner of the area where the paste will occur. If copying and pasting a chart then this selection is not necessary.

4. Invoke the Paste Command to paste the copied items from the System Clipboard onto the selected location. The copied items remain on the Clipboard and can be used for more than one Paste Command.

   Note that, if there are repeats in the selection, then these are also copied, if all of the stitches inside the repeats are also selected. There are occasions when you might want to copy some stitches but do NOT wish to copy the repeats, for example if you have a stitch pattern inside a repeat but wish to adapt this for a side panel where there will be no repeats. In this, the copying of repeats can be turned off by with a preference setting. To change this preference select Tools > Preferences > Knitting Chart Editor from the main menu. The setting is labelled 'Do not copy repeats when copying stitches'. Note that this preference setting only applies when stitches are copied. Repeats are always included in a copy when rows, columns or charts are copied.

**Invoking the Copy Command.**

Once items have been selected the Copy command can be invoked in any of the following ways:-

1. On the main menu bar, select Edit > Copy.

2. On the main tool bar, select the Copy Icon.

3. Use the keystroke Control+C (on Windows) or Cmd+C (on Mac).
Invoking the Paste Command.

Once items have been selected the Paste command can be invoked in any of the following ways:-

1. On the main menu bar, select Edit > Paste.
2. On the main tool bar, select the Paste Icon.
3. Use the keystroke Control+V (on Windows) or Cmd+V (on Mac).

Copy Dragging.

To copy and paste rows, columns and stitches using Copy Dragging:-

1. Select the items to be copied. Selected items should be of the same type, for example only rows or only columns or only stitches but not a mixture of these.
2. Hold down the Control (Windows) or Alt (Mac) key.
3. Click down on any of the selected items and then, whilst the button is still down, move the mouse to drag a copy of the selected items.
4. Release the mouse button to finish dragging and invoke the paste.

Copying Columns that contain Wide Stitches

If a column contains a stitch that spans more than one column, such as a cable stitch, then all columns that include that stitch must be selected before copy and paste commands are enabled.

Moving Charts, the Key and Chart Elements

Rows, columns or stitches can be moved within a chart or from one chart to another within the same diagram file by dragging them. Charts and the key can be dragged anywhere on the canvas and also be automatically arranged.

Moving Rows, Columns and Stitches

To move rows, columns and stitches:-

1. Select the items to be moved. (see Selection Tools). Selected items should be of the same type, for example only rows or only columns or only stitches but not a mixture of these.
2. Click down on any of the selected items and then, whilst the button is still down, move the mouse to move the selected items.
3. Release the mouse button to finish moving.

When moving rows and columns, it is the contents of the rows and columns that are moved rather than the rows or columns themselves. The original rows and columns are filled with knit stitches and the default colour / yarn.

When moving rows from one chart to another, each chart must have the the same number of columns, otherwise strange things happen. Likewise when moving columns, the number of rows must match.
The selection should not contain hidden 'no stitches' as this will cause strange results. To move areas of a chart containing hidden 'no stitches' first unhide the hidden stitches by selecting either the chart or row(s) and selecting Edit > Show Hidden Items in Selection from the main menu.

Rows, columns and stitches can only be moved within a chart diagram file. To copy chart elements to a chart in another chart diagram file use Copy and Paste (see Copying and Pasting).

**Moving Columns that contain Wide Stitches or Repeats.**

If a column contains a stitch or repeat that spans more than one column, such as a cable stitch, then all columns that include that stitch should be selected before moving.

**Moving Charts and the Key**

To move a chart or a key;-  
1. Select the chart or key to be moved (see Selection Tools).  
2. Click down on the selected item and then, whilst the button is still down, move the mouse to move the selected item.  
3. Release the mouse button to finish moving.

The charts and key within a chart diagram file can also be arranged automatically by selecting the Arrange icon from the main toolbar.

Charts can only be moved within a chart diagram file. To copy a chart to another chart diagram file use Copy and Paste (see Copying and Pasting).

**Inserting and Deleting Rows and Columns**

**Inserting Rows**

To insert a new row into a chart;-  
1. Select an existing row (see Selection Tools).  
2. On the main menu bar, select either Insert > Insert Row(s) > Insert Row(s) above the Selected Row(s) or Insert > Insert Row(s) > Insert Row(s) below the Selected Row(s).  
3. A row of knit stitches with the default yarn / colour is inserted. The selected row will be used as a template for placing borders and repeats. Hence, if all stitches between columns 3 and 8 in the selected row are in a Round Bracket Repeat that is to be repeated 3 times and has a red border entitled 'Main Pattern Repeat', then the new row will also have all stitches between columns 3 and 8 in a similar repeat and with the same border.

To insert more than one row, select the appropriate number of rows in step 1.

**Inserting Copied Rows**

To insert a copied row into a chart;-  
1. Copy an existing row to the System Clipboard (see Copying and Pasting Chart Elements).
2. Select an existing row (see Selection Tools).

3. On the main menu bar, select either **Insert > Insert Copied Row(s) > Insert Copied Row(s) above the Selected Row(s)** or **Insert > Insert Copied Row(s) Insert Copied Row(s) below the Selected Row(s)**.

4. The copied row on the System Clipboard is inserted. The selected row will be used as a template for placing borders and repeats. Hence, if all stitches between columns 3 and 8 in the selected row are in a Round Bracket Repeat that is to be repeated 3 times and has a red border entitled 'Main Pattern Repeat', then the new row will also have all stitches between columns 3 and 8 in a similar repeat and with the same border.

To insert more than one copied row, select the appropriate number of rows in steps 1 and 2.

**Deleting Rows**

To delete rows from a chart:-

1. Select the row(s) to be deleted (see Selection Tools).

2. On the main menu bar, select either **Edit > Cut** or **Edit > Delete**.

Alternatively use the keystrokes **Control + X** (on Windows) or **Cmd + X** (on Mac) or select the Cut / Delete Icons from the toolbar.

**Inserting Columns**

To insert a new column into a chart:-

1. Select an existing column (see Selection Tools).

2. On the main menu bar, select either **Insert > Insert Column(s) > Insert Column(s) to the Right** or **Insert > Insert Column(s) > Insert Column(s) to the Left**.

3. If the selected column contains a stitch that spans more than one column, such as a cable stitch, then columns can only be inserted if the new column does not disrupt the wide stitch. Hence the Insert Column(s) to the Left / Right commands will be disabled / enabled as appropriate.

4. A column of knit stitches with the default yarn / colour is inserted. The selected column will be used as a template for placing borders and repeats. Hence, if the selected column is inside a repeat then the new column will also be inside that repeat. If all stitches between rows 2 and 6 in the selected column have a red border entitled 'Main Pattern Repeat', then the new column will also have all stitches between rows 2 and 6 with the same border.

To insert more than one column, select the appropriate number of columns in step 1.

**Inserting Copied Columns**

To insert a copied column into a chart;-:

1. Copy an existing column to the System Clipboard (see Copying and Pasting Chart Elements).

2. Select an existing column (see Selection Tools).
3. On the main menu bar, select either **Insert > Insert Copied Column(s) > Insert Copied Column(s) to the Right** or **Insert > Insert Copied Column(s) > Insert Copied Column(s) to the Left**.

4. If the selected column contains a stitch that spans more than one column, such as a cable stitch, then columns can only be inserted if the new column does not disrupt the wide stitch. Hence the Insert Column(s) to the Left / Right commands will be disabled / enabled as appropriate.

5. The copied column on the System Clipboard is inserted. The selected column will be used as a template for placing borders and repeats. Hence, if all stitches between rows 2 and 6 in the selected column have a red border entitled 'Main Pattern Repeat', then the new column will also have all stitches between rows 2 and 6 with the same border.

To insert more than one copied column, select the appropriate number of columns in steps 1 and 2.

### Deleting Columns

To delete columns from a chart:

1. Select the column(s) to be deleted (see Selection Tools).

2. On the main menu bar, select either **Edit > Cut** or **Edit > Delete**.

Alternatively use the keystrokes **Control+C** (on Windows) or **Cmd+C** (on Mac) or select the Cut / Delete Icons from the toolbar.

If a column contains a stitch that spans more than one column, such as a cable stitch, then all columns that include that stitch must be selected before delete commands are enabled.

### Editing Chart Properties

To edit the properties of a chart:

1. (Optional) Select the chart to be edited (see Selection Tools). If there is only one chart in a Chart diagram file then this step is not necessary.

2. On the main menu bar, select **Chart > Edit Chart Properties**. The Edit Chart Properties dialog opens.
3. (Optional) Edit the **Chart title**. For diagrams with more than 1 chart, each chart must have a unique title.

4. (Optional) Edit the **First row number** and **First column numbers**.

5. (Optional) Select the positioning of **Column numbers**. Note that individual column numbers can be either hidden or edited later.

6. (Optional) Select if the chart represents **Circular**, **Flat** or **Mosaic** knitting.

   Charts for flat knitting always alternate right side (RS) and wrong side (WS) rows. Charts for circular knitting have only RS rows. Charts for mosaic knitting alternate two RS rows with two WS rows. RS rows have the row number at the right hand side of the chart, whilst those of WS rows are on the left hand side.

   An alternate form of chart for mosaic knitting that has a row number at both ends is not yet supported by StitchMastery but will be added in a future version.

   (Optional) Select if the chart should start with a RS or WS row. This option is only enabled for flat or mosaic knitting.

   (Optional) Select if the WS rows should be hidden. This option is only enabled for flat knitting. Support to hide rows for other chart forms will be added in a future version.

7. (Optional) **Key Text**: The text for key entries is generated when a chart is first created or when a new entry is added, for example, when a stitch is used in a chart for the first time. If the chart has been changed from flat to circular or vice versa or if the stitch library or text template has been edited, then the key text might be out of date. StitchMastery does not automatically update the key text as doing so would overwrite any manual edits.

   To refresh the key text, select **Refresh text in key** and check that the desired text template is selected.

8. Select **OK**.

### Editing Diagram Properties.

Some properties relate to all the elements in a Chart Diagram file rather than to individual charts. This includes the stitch library and stylesheets associated with this chart diagram file. For more information about stitch libraries see StitchMastery Libraries. To find out more about stylesheets see About Stylesheets. If no user stitch libraries or stylesheets have been created yet then only the StitchMastery ones will be listed.

1. On the main menu bar, select **Chart > Edit Diagram Properties**. The Edit Diagram Properties dialog opens.
2. Check that the Appearance tab is selected.

   The current appearance stylesheet contains values for fonts, grid, grid highlighting, annotations and symbol contrast but these do not necessarily match the values shown in the Appearance tab. This is because they can all be individually edited to override the values from the stylesheet. The values that are displayed when the Edit Diagram Properties dialog is first opened are the current values set on that chart diagram file irrespective of the values in the stylesheet.

   To reset all of the values for grid, grid highlighting, annotations and symbol contrast so that they match the current appearance stylesheet press **Apply**.

3. (Optional) **Stylesheet**: A list of all of the appearance stylesheets known to Stitchmastery is displayed and can be selected from.

   To reset all of the values for **Grid**, **Grid highlighting**, **Annotating repeated stitches** and **Stitch symbol contrast** so that they match a different appearance stylesheet, first select the stylesheet and then press **Apply**.

4. (Optional) The values for **Grid**, **Grid highlighting**, **Annotating repeated stitches** and **Stitch symbol contrast** can also be edited independently of the stylesheet. Note that these values apply to all of the charts and the key in the diagram file.

5. The current values for the fonts used by the text are not displayed in this dialog as they can be edited at an individual level, that is a single row number can have a different font to all other row numbers. To edit the fonts for individual elements use the **Edit Font** command. For more information on how to do this see Editing the Text Fonts.

   To reset the text fonts so that they match the values in the appearance stylesheet, select **Refresh font of all text**.

6. (Optional) Select the **Default stitch type** to be used when creating a chart or adding rows or columns. Available choices are knit, purl and two variants of 'no stitch'.

7. Select the **Written Instructions** tab.

8. (Optional) **Written stylesheet**: A list of all of the Written stylesheets known to Stitchmastery is displayed and can be selected from.

9. If **Include colour in written instructions** is selected, then colour is included in the written instructions in the Outline Text view and in the output from Export to View.

10. Select the **Stitch Library and Text Templates** tab.
11. (Optional) **Stitch library**: A list of all of the stitch libraries known to Stitchmastery is displayed and can be selected from.

12. (Optional) **Text templates stylesheet**: A list of all of the Text Template stylesheets known to Stitchmastery is displayed and can be selected from.

13. (Optional) **Key Text**: The text for key entries is generated when a chart is first created or when a new entry is added, for example, when a stitch is used in a chart for the first time. If the chart has been changed from flat to circular or vice versa or if the stitch library or text template has been edited, then the key text might be out of date. Stitchmastery does not automatically update the key text as doing so would overwrite any manual edits.

   To refresh the key text, select **Refresh text in key** and check that the desired text template is selected.

14. Select **OK**.

### Working with the Chart Diagram Key

As stitch types and colours (yarns) are selected from the palette and used in a chart, relevant entries are automatically added to the key in the Chart Diagram. Hence, the default colour (yarn) and stitch type that are used to create the initial chart are added to the key when a new chart is created. In addition, entries for borders are added to the key as these are created.

The key is highly customisable. The labels of individual key entries is automatically generated using templates that can be edited by the user. (see Editing a user Text Templates stylesheet for more information about editing the key entry templates). After the labels have been generated by the Knitting Chart Editor, they can be further edited by the user. Key entries can also be reordered, deleted (if possible) or hidden (when it is not possible to delete).

### Editing Key Properties

The layout of the key can be changed from the default vertical layout. To edit the key:

1. On the main menu bar, select **Key > Edit Key Properties**. The Edit Key Properties dialog opens.
2. (Optional) Edit the key title.

3. (Optional) Layout of Key Entries: Select between Single Row, Single Column or Multiple Columns.
   If Multiple Columns is selected then enter the number of columns and if they should have equal width.

4. Select OK.

**Editing Key entries**

To edit individual Yarn (Colour) or Border entries;-

1. Select the entry in the key (see Selection Tools).

2. On the main menu bar, select either **Border > Edit Border Properties** or **Yarn > Edit Yarn Properties** as appropriate. Either the Edit Border dialog or the Edit Yarn dialog opens.

3. Change properties as desired.

4. Select OK.

Stitch type entries are edited by customising the palette (See Working with the Stitch Library).

To edit the labels of individual key entries (including those of stitch types) use direct editing as follows;-

1. Select the label in the key by clicking once anywhere on the label text.

   ```plaintext
   Key
   [ ] knit
   [ ] purl
   [√] slip purlwise with yarn in front
   ```

   The label will show selection with a thin black outline.

2. Click again anywhere on the label text.
The label will change to an editable text box with a white background.

3. Edit the text.

Using the keystroke **Control+Enter** creates a new line.

4. Pressing Enter updates the label to the entered text.

### Deleting Key Entries

Individual entries can be deleted from the key. If the entry is for a border then deleting the entry also deletes the border and removes the border from all stitches in the chart.

If the entry is for a yarn (colour) or for a stitch type then, if the yarn or stitch type is used by any stitch in the chart, then the user will be prompted to replace the yarn or stitch type with an alternative. The default yarn cannot be deleted but can be hidden.

To delete an entry:-

1. Select the entry in the key (see Selection Tools).
2. On the main menu bar, select either **Edit > Cut** or **Edit > Delete**.
3. (Optional) If the yarn or stitch type is in use, either the Replace Stitch Type dialog or the Replace Yarn dialog opens.
4. Select an alternative yarn / stitch type.
5. Select **OK**.

Alternatively use the keystrokes **Control+X** (on Windows) or **Cmd+X** (on Mac) or select the Cut / Delete Icons from the toolbar.

### Hiding Key Entries

Individual entries can be hidden rather than deleted.

To hide an entry:-

1. Select the entry in the key (see Selection Tools).
2. On the main menu bar, select **Edit > Hide Selection**.

### Showing Hidden Entries

To show key entries that have previously been hidden:-
1. Select the key (see Selection Tools) or the key label.

2. On the main menu bar, select **Edit > Show Hidden Items in Selection**.

More information on hiding both key and chart elements can be found in Hiding and Showing Chart Elements.

**Reordering Entries.**

Key entries can be reordered only when the key layout is set to Single Column. The layout can temporarily be set to Single Column in order to reorder entries. When changing layouts the placing of entries into columns always occurs in the same way so that predicting which column an entry will be in is possible.

The reordering occurs as follows:

1. Click down on the entry to be moved and then, whilst the button is still down, move the mouse to drag the entry to a new position.

2. Release the mouse button to finish dragging.

**Editing the font.**

The text used both for the key title text as well as for individual key entries can be edited (see Editing the Text Fonts).

**Overriding automatic numbering of Row and Column Labels**

When a chart is created, the row and column labels are numbered starting with the chosen row and column number. As rows and columns are inserted and deleted, the labels are automatically renumbered. There are occasions when you may wish to override this automatic updating and label individual rows and columns differently.

If you wish to remove a row or column label altogether then you can also do this by hiding it (see Hiding and Showing Chart Elements for more details).

Note that after a row or column label has been either edited or hidden, automatic renumbering still occurs but the edited / hidden row / column label is no longer updated.

**Editing Row or Column Labels**

To edit an individual Row or Column Label use direct editing as follows:

1. Select the row or column (see Selection Tools).
The row or column will show selection with a thin black outline.

2. Click again anywhere on the label of the row or column.

An editable text box will appear next to the label. If the row or column label is currently being updated automatically, the text box will be empty. If, however, the row or column label has previously been edited, then the current value of the label will be in the edit box.

3. Edit the text. Using the keystroke Control+Enter creates a new line.

4. Pressing Enter updates the label to the entered text.

Note that the width of the row label is adjusted to accommodate the text but the height of row labels is fixed to the height of the grid cell. To fit text into the height of the row label, adjust the size of the font used (see Editing the Text Fonts). Similarly the width of column labels is fixed to the width of the grid cell.

**Resetting Row or Column Labels**

If you have edited a row and column label but wish to reset it so that the label is automatically numbered, you can do this by either using direct editing to set the label to have no text or by using the Reset Row / Column Id command.

To reset a row or column label by using direct editing:

1. Follow the instructions given in Editing Row or Column Labels to select the label and show the edit box.

2. When the edit box appears, delete all of the text so that the text cursor which is a vertical line, is at the leftmost position of the text box.

3. Pressing Enter will now remove all custom edits on the label and the label will revert to being renumbered automatically.
Note that this method works best if you have only a single label to reset. If you have several labels to reset, it is best to use the following method:-

To reset a row or column label by using the Reset Row / Column Id command:-

1. Make a selection that contains all of the row or column labels that you would like to reset. For example, if you wish to reset all of the labels in a chart, then select the chart. If you only wish to reset some of the row labels in a particular chart, then select only those rows. If no selection is made, then all rows and columns in all of the charts in the diagram file will be reset.

2. Select Edit > Reset Row/Column Id from the main menu.

Hiding Row and Column Labels.

Row and column labels can be hidden by directly editing the labels so that the text is a single space. This is only useful if you wish to hide a single label, however, as it is tedious to directly edit several labels. To hide several row and column labels, see Hiding and Showing Chart Elements for information on using the Hide / Show commands.

Hiding and Showing Chart Elements

Some chart elements can be hidden in order to customise the look of the chart. These elements include 'no stitch' stitches, row and column labels and key entries.

Hiding 'no stitch' stitches

There are two methods to hide 'no stitch' stitches. The choice of method depends on the positioning of the 'no stitch' stitches and the effect that you would like to achieve.

To hide 'no stitches' that are at the ends of rows to create irregularly shaped charts:-

1. Select the chart (see Selection Tools). Note that, if this is the only chart in the chart diagram file, this step is not necessary.

2. On the main menu bar, select Edit > Hide No Stitch Edges

3. All 'no stitch' stitches that are at the ends of rows will be hidden to create an irregular chart.
However, if not all the 'no stitch' stitches are at the ends of rows, then a different method should be used. For example, the 'no stitches' on the right hand side of the following chart are not at the ends of rows;

In this case, using the **Hide all No Stitches in Selection** is more appropriate.

To hide 'no stitches' that are not at the ends of rows;

1. Make a selection that contains all of the 'no stitches' that you wish to hide. For example, if you wish to hide all of the 'no stitches' in a chart, then select the chart. If you only wish to hide some of the 'no stitches' in a particular chart but not others then select only those rows. If no selection is made, then all 'no stitches' in all of the charts in the diagram file will be hidden.

   For example, in the following chart all of the 'no stitches' in rows 3-7 should be hidden but not those in row 2. Hence a row selection is made:

2. On the main menu bar, select **Edit > Hide all No Stitches in Selection**

3. All 'no stitch' stitches that are in the current selection will be hidden.
To show 'no stitches' that are currently hidden:

1. Make a selection that contains all of the 'no stitches' that you wish to show. For example, if you wish to show all of the 'no stitches' in a chart, then select the chart. If you only wish to show some of the 'no stitches' in a particular chart but not others then select only those rows. If no selection is made, then all 'no stitches' in all of the charts in the diagram file will be shown.

2. On the main menu bar, select **Edit > Show all No Stitches in Selection**

3. All 'no stitch' stitches that are in the current selection will be shown.

**Some drawbacks of hiding 'no stitch' stitches.**

When a 'no stitch' stitch is 'hidden', it effectively does not exist on the drawing canvas and so cannot be selected. With the present version of the software, this can cause unexpected effects if you are still editing the chart using the Copy, Paste, Move tools etc.

To avoid this issue, it is best to wait until editing is finished before hiding the 'no stitch' stitches. If you have already hidden the 'no stitch' stitches and wish to do some editing, the 'no stitch' stitches should be unhidden before editing.

**Hiding Row and Column Labels**

The positioning of row labels depends on whether the row is a right side (RS) row or a wrong side (WS) row. This positioning reflects the starting point for the knitter when working from the chart. RS rows always have the row label at the right hand side, whilst WS rows always have the row label at the left hand side.

The positioning of column labels is determined by the user and can be changed (see Editing Chart Properties).

The contents of the row and column labels can be edited (see Overriding automatic numbering of Row and Column Labels but they can also be hidden).

This can be useful for irregular shaped charts as in the example below:
To hide row and column labels:

1. Select the relevant row or columns (see Selection Tools).
2. On the main menu bar, select **Edit > Hide Row/Column Id**.
3. The row or column labels for the selected rows or columns are then hidden.
Note that in this example Edit > Hide No Stitch Edges has also been used to hide the 'no stitch' stitches.

To show the hidden row or column labels:-

1. Select the relevant row or columns.
2. On the main menu bar, select **Edit > Show Row/Column Id**.
3. The row or column labels for the selected rows or columns are then shown.

### Hiding Key Entries

The Knitting Chart Editor automatically adds entries to the keys as stitches, yarns (colours) and borders are added. It does not delete them automatically as monitoring whether or not a stitch is in use would adversely affect the performance. However, if a stitch, yarn colour or border is not in use, then it can be deleted by using the Cut / Delete icons on the toolbar.

There are times, however, when a key entry cannot be deleted because it is for a stitch, yarn or border that is still in use, but the user still wants to hide it.

An example is given in the chart below where all of the stitches are worked in knit. Because the chart is for colourwork, the entry for the knit stitch is superfluous and the user would like it hidden.

To hide key entries:-

1. Select the relevant key entry (see Selection Tools).
2. On the main menu bar, select **Edit > Hide Selection**.
3. The selected key entry is then hidden.
To show the hidden key entry:

1. Select the key.

2. On the main menu bar, select **Edit > Show Hidden Items in Selection**.

3. The key entry is then shown.

**Editing the Text Fonts**

The default font used for any of the text labels in either the key or any of the charts is set via the Software Preferences. If you have a particular font that you would always like to use for the text labels, then set the default font using the preference setting. This font is the one used when either a chart, column or row, etc. is created.

These fonts, though, can easily be edited at any time.

To edit the font used by a label:

1. Make a selection that contains all of the labels that you would like to reset. For example, if you wish to edit the font for all of the labels in a chart, then select the chart. This will include all of the row and column labels as well as the chart title. If you only wish to edit the font for some of the row labels in a particular chart, then select only those rows. Similarly, selecting the key will enable font editing for all of the key entries as well as the key title. Selecting a single key entry will enable font editing for only that key entry. If no selection is made, then all labels in all of the charts and in the key will have their font edited.

2. Select **Edit > Edit Font** from the main menu or select the Edit Font icon from the main toolbar.

3. The Font dialog opens allowing you to select any font installed on your system. You can change the font or the font style, size or colour.

4. Select the desired font.

5. Select **OK**. The labels within the current selection will be updated to the selected font.
Replacing Stitches and Yarns/Colours

To replace a yarn (colour) or stitch type that is used by any stitch in the chart, delete the relevant entry from the key. As the entry is deleted from the key the user will be prompted to replace the yarn or stitch type with an alternative.

To replace a yarn or stitch type:-

1. Select its entry in the key (see Selection Tools).

2. On the main menu bar, select either Edit > Cut or Edit > Delete. Either the Replace Stitch Type dialog or the Replace Yarn dialog opens.

3. Select an alternative yarn / stitch type.

4. Select OK.

Alternatively use the keystrokes Control + X (on Windows) or Cmd + X (on Mac) or select the Cut / Delete Icons from the toolbar.

Changing the Chart Diagram Layout

To change the position of a chart or a key:

1. Select a location on the chart or key that is within the bounds of the chart or key but does not contain other items (see Selection Tools).

2. Hold down the mouse button but do not release the button yet.

3. Move the mouse to the drag the item to a new location.

4. Release the mouse button to finish moving.

Using the Arrange command.

The Arrange command provides a quick way to quickly layout all the charts and the key in the Chart Diagram file. It is invoked by selecting the Arrange Icon from the main tool bar. All the charts are laid out in a horizontal row with the key being placed at the right hand side.

Automatic layout.

When columns are added to a chart or a new chart is added to the Chart Diagram file, the key needs to be shifted to the right so that the charts do not overlap the key. By default this happens automatically. If, however, you have changed the layout of the chart(s) and key manually, then you may wish to turn off this automatic layout so that it does not undo your hard work. This can be done by unselecting the 'Automatically arrange charts and key' preference option. For more information see Preferences.

Annotating repeated stitches

About Annotations

When there are repeated stitches in a chart, annotations showing the number of such stitches can make a chart faster and easier to read. The Stitchmastery Knitting Chart Editor has the ability to detect these
stretches of repeated stitches and to automatically annotate them on the chart. It is relatively easy to get Annotations to be displayed and many options are also available to customise their appearance.

Some examples of Annotations

There are many situations where Annotations for repeated stitches can be very useful. To illustrate how powerful the Annotations feature of Stitchmastery is and how it is possible to customise them to display in very different ways in order to suit the chart, two examples are shown. These two examples are not exhaustive of the possible situations where Annotations can be used or of the different ways that they can be customised. Feel free to play with the different values for customising them to get the look that you want!

The first example is of a lace chart.

In this example annotations are displayed for all stretches that are 5 stitches or longer. The annotations have been centred both horizontally and vertically in the stretch of repeated stitches which means that the numbers are often in front of the grid lines. Hence the white background, rather than a transparent background, is used for the number so that it stands out against the grid lines.

The second example is for a colourwork chart.

As before, annotations are displayed for all stretches that are 5 stitches or longer. Because the backgrounds of the cells are not white, the **Number background transparent** value has been selected. In order that the
numbers are not then in front of the grid lines the horizontal position has been edited so that all the numbers are in the top right corner of the repeat stretch. In addition, to ensure that the number stands out against the coloured backgrounds, the **Automatically contrasts with yarn colour** value has been selected. In order for the latter to work, the **Include colour in written instructions and for repeated stitches** value has been selected in the **Written** tab of the Edit Diagram Properties dialog. See Editing Diagram Properties for more details.

### Values for Annotations

Below are listed the different values that can be used to customise how Annotations are displayed.

1. In order to show annotations and be able to edit the annotations values, select **Display Annotations**.

2. The **Minimum number of stitches** defines the number of similar stitches that must be next to each other before an annotation is displayed. Any 'stretch' less than this number is not annotated. This number must be between 3 and 9.

3. Select **Number background transparent** to have the number drawn with a transparent background. If not selected, the number is drawn with a white background. A transparent background is useful for a colourwork chart, whilst a white background is best if the number is in front of symbols and grid lines.

4. If **Automatically contrasts with yarn/colour** is selected then, if the background colour is dark the number colour swaps to white. Note that this only works if **Include colour in written instructions** is also selected.

5. The font for the numbers can be selected.

6. There are four options for the horizontal positioning of the annotation number within the stretch of repeated stitches; **Left**, **Right** and **Centre** position in the number to the left, right or centre of the stretch respectively. **Beginning** places the number at the beginning of the stretch. That is, for right side rows and for charts worked in the round, the number is always on the right hand side, whilst it is on the left for wrong side rows.

7. The vertical position can be set to either **Top**, **Bottom** or **Middle**

8. Once the number's horizontal and vertical positions have been set, its exact location can be fine tuned by editing the **Gap at sides** and **Gap at top/bottom** values. However, these values have no effect if the number is centred.

### Editing values for Annotations

There are two ways that values can be edited:-

1. **Editing the values for each chart diagram file**. The values for each individual file can be edited by using **Diagram > Edit Diagram Properties**. See Editing Diagram Properties for more details.

   This is a good way to quickly change the values for an individual file and to experiment with different values. However, if you would like to have annotations on all or many of your chart diagram files, then you will save time by using the second option below.

2. **Create a user Appearance stylesheet**. If you find yourself editing the same values for more than one chart diagram file then it is worth your while setting up a stylesheet with those values and using it as the active stylesheet. See Creating a user stylesheet for details of how to create the user stylesheet.

   Once a stylesheet has been created it still needs to be set as the 'active' Appearance stylesheet on a chart diagram file. The 'active' stylesheets can be selected when a chart diagram file is created. If a chart
diagram file exists already and you want to change the 'active' Appearance stylesheet this can be done by using **Diagram > Edit Diagram Properties**. See Editing Diagram Properties for more details.
Chapter 3. Working with the Stitch Library

About Stitch Libraries

A major feature introduced in version 2 of Stitchmastery are multiple stitch libraries and the possibility to swap between them. Both the format of chart files and stitch libraries as well as the way that stitch libraries are organised and edited are major changes from version 1. Support is provided to open version 1 chart files (’.knit’) files in ‘compatibility’ mode as well as to convert version 1 chart files and stitch library to the new version 2 formats.

Version 1 files

In version 1 chart files have a file extension of ’.knit’. There is a single Stitchmastery library that uses the ’Dot’ family of Stitchmastery fonts and a single user library that extends it. This is shown in the diagram below.

Version 2 files

In version 2 chart files have a file extension of ’.knt2’. User stitch libraries have a file extension of ’.smlib’. There are multiple system and user libraries. Chart files reference stitch libraries indirectly through aliases that are stored in Preferences. Using an alias means that chart files and any associated user stitch library can be viewed and edited on different computers and it does not matter that the files may be in different folders.
Working with the Stitch Library

Each alias uses a combination of the stitch library name and the user namespace. Each combination of name and namespace must be unique. In order to create a version 2 user stitch library, a value for the namespace should be stored in Preferences. For more information about namespaces see ...link to be added.

Opening Version 1 files in Version 2

Version 1 files can be opened in version 2. They are opened in compatibility mode only. This means that they can be viewed and charts and output text can be exported from them. However, while edits to the .knit file are possible, these are discouraged and the saving of any edits is disabled. Editing of the version 1 stitch library is disabled.

In order to edit a version 1 chart file it should first be converted to the version 2 format. This is done using the Save as command. This creates a copy of the original file but in version 2 format and with a `.knt2` file extension. The original chart file is not changed.

At the same time, if Stitchmastery finds a version 1 user stitch library file on the machine and it has not already been upgraded, it is also upgraded to the version 2 format. A copy of the library is created in a file with a `.smlib` file extension and an alias for it stored in Preferences. The original version 1 library is not changed. A Preference option saves the alias of the upgraded library so that it can be used when converting other version 1 chart files.
Stitchmastery Libraries

There are two Stitchmastery libraries in Stitchmastery 2.0. Both contain the same stitches and both are in English. The only difference between them is that they are based on a different ‘family’ of Stitchmastery fonts. The Stitchmastery Dot English library uses fonts that use the convention of a blank space to represent knit stitches and a dot to represent purl stitches. The Stitchmastery Dash English library, on the other hand, uses fonts that use the convention of a vertical dash for knit stitches and a horizontal dash for purl stitches.

The stitch definitions in each of the libraries are linked to each other so that Stitchmastery knows that the knit stitch in the 'Dot' library is related to the knit stitch in the 'Dash' library.
Hence, by swapping the library on a chart file it is possible, with minimal effort, to change the symbols in a chart. Because the Stitchmastery libraries are organised by a theme, i.e. 'Dot' and 'Dash', the resulting appearance is consistent and understandable. The example below shows a chart created with the 'Dot' Stitchmastery library.

By changing the stitch library to the 'Dash' Stitchmastery library, the appearance of the chart is quickly changed:

In the case of the two Stitchmastery libraries, because the only difference is the stitch appearance, there is no change to the output text when a stitch library is changed. However, by using a User stitch library it is also possible to customise both the output text and the text for key entries.

**User Stitch Libraries**

A User stitch library is based on one of the Stitchmastery libraries. Edits by the user either customise stitches in the Stitchmastery library or add completely new stitches. When a 'system' stitch is customised the resulting customised stitch takes precedence over the 'system' stitch. The resulting view that a user has
of a stitch library is a mixture of stitches contributed by both the Stitchmastery library and by user edits. This is indicated by the green arrows in the diagram below.

The linking of stitches between Stitchmastery and user libraries is an important feature as it means that Stitchmastery can correctly swap stitches, even user customised ones, when a stitch library is swapped. Only stitches that are 'linked' to a 'system' stitch can be swapped in this way. Stitches that are created by 'adding' a stitch to a User library are not linked to a 'system' stitch and so cannot be swapped. This is illustrated in the diagram below where the 'Golden Snitch' stitch has been added to the chart using a User stitch library.

When the stitch library is later swapped to the 'Dot' Stitchmastery library, the Golden Snitch stitch remains unchanged as shown here:-

When the stitch library was swapped, the option to refresh the text for the key entry was selected so that the key text for the cable stitches is also updated. The written instructions in the Output Text view are generated every time that the chart is updated so any changes to stitches are automatically reflected there. Compare the two diagrams below to see these changes.
Because of the linking between system and user customised stitches, it is recommended that, if you would like to edit stitches to suit your own charting needs and preferences, that you first double check if a version of the stitch exists in the Stitchmastery libraries. If it does, then it is recommended that you customise this stitch rather than adding a new one.

At present both Stitchmastery libraries are in English. However, it is planned to add Stitchmastery libraries in other languages in the future.

**Viewing and editing stitch libraries**

Because multiple stitch libraries are now available and to tie them in with other preference options such as stylesheets the main access point for creating and editing stitch libraries is now under Preferences. This is a major shift from version 1. It is still possible to edit a user stitch library from the Palette when a chart file is open but only when the chart file is in version 2 format and the current stitch library is a User Stitch Library. Both approaches are documented below.

**Viewing and editing stitch libraries via Preferences**

1. Open the Preferences dialog. See Preferences for more details.

2. Select **Knitting Chart Editor → Stitch Libraries** to see all the stitch libraries that are currently known to Knitting Chart Editor.

---

**Chart**

Round 1: Knit. (8 sts)
Round 2: K2, C2FP, C2BP, k2.
Round 3: (K2, p) x 2, k2.
Round 4: K, ssk, p, k2, p, k2tog, k.
Round 5: K, p, snitch x 2, p, k. (6 sts)
Stitchmastery libraries and user libraries are displayed under separate tabs. Currently there are two Stitchmastery libraries. See Stitchmastery Libraries for more details.

Initially there will be no user stitch libraries (unless you have upgraded a version 1 library). See Creating a User Stitch Library to find out how to create a user stitch library.

Default stitch library: when creating a new chart diagram file, its stitch library alias is set to the current default stitch library unless another stitch library is specifically chosen. The stitch library of a chart diagram file can be changed later by selecting Diagram → Edit Diagram Properties.

If Stitchmastery finds a version 1 stitch library on the machine, then the following options are also displayed:

Stitch library to be used when upgrading version 1 .knit files to version 2 format: the stitch library selected here will be used. The list of stitch libraries from which a selection can be made contains the system 'dot' library as well as all user stitch libraries that extend the system 'dot' library. This is because the system 'dot' library was the default system library in version 1 and so gives the minimum change when upgrading. The stitch library of a chart diagram file can be changed later.

Upgrade Version 1 Stitch Library to new Version 2 file: allows for creating a fresh version 2 file from the version 1 library. See Upgrading version 1 Stitch Library to version 2 format for more details.
Viewing a Stitchmastery library

1. To view a Stitchmastery library, select one of the libraries from the Stitchmastery libraries tab and then View.

2. The Stitch Library dialog opens. As this is a Stitchmastery library that is being viewed the dialog is in 'Read Only' mode.

There are two views of the stitch library; the table view and palette view. Swap between the views by selecting the appropriate tab.

3. In the table view all stitches in the library are displayed in a table. The visible entries can be filtered by entering text in the Filter box. By default the filter text is matched to text in the Name column. However, the matching can be changed by using the Column to filter drop down selection. The example below shows the Column to filter set to the Drawer column. By entering 'cables' into the Filter box, only stitches in any of the drawers with 'cables' in their name are displayed.
4. Sometimes the width of the column is not wide enough to display its contents. For example the Appearance column is not wide enough to show the wide column stitches. In this case the column can be sized by dragging the column header to the side. The location to drag the column is circled in red in the screenshot below. For those columns that contain text, the full text in the column can be displayed by hovering with the mouse over the text until a tooltip appears.

5. In the palette view all the drawers in the palette and all of their contents are displayed in the same structure as in the palette. To show or hide the contents of a drawer click on the triangular icons to the left hand side of the drawers. They are circled in red in the screenshot below.
6. To view a stitch in more detail either double click on the stitch or select the stitch and then select View.

7. The View Stitch dialog opens to show details of the selected stitch type.

8. For an explanation of the different values and how they are used by the Knitting Chart Editor see Editing a user stitch library.

**Creating a user stitch library**

1. To create a user library, select one of the libraries from the Stitchmastery libraries tab and then Extend.

2. If this is the first time that you have created a user stitch library or stylesheet and the 'Namespace' value has not yet been set, the Configure Namespace dialog will prompt you to enter a 'namespace' value. The 'namespace' is an identifier that is used to label the stitch libraries and stylesheets that you create. It is important to choose a value that is unique to you to make it easier to share stitch libraries and stylesheets with others. For more information on choosing a namespace see What's a namespace?

   It is possible to change the namespace later but it is not possible to apply such a change to any existing stitch libraries or stylesheets.
Enter a value for namespace and then select **OK**.

3. The Create new User Stitch Library dialog opens

Name contains a generated name. If desired, type in a different name. The combination of name and namespace must be unique as these are used for the alias that is referenced from a .knt2 file. It is **NOT** possible to change the name of a stitch library at a later date as this would invalidate the alias.

Namespace defaults to the current namespace value. It is **NOT** possible to change this value as this would invalidate the alias.

Description is copied from the extended library. If desired this text can be edited. It is possible to edit it later.

Language is copied from the extended library. This is used to identify non-english libraries to supress warnings about non-english characters that would cause problems if parsing using the text to chart feature. If desired select another language. It is possible to edit it later.

Folder defaults to the home directory. To select a different directory use the Browse button.

File name contains a generated default name. If desired, type in a different file name. The file extension must be ".smlib".
4. The Stitch Library dialog opens ready for editing. For details of editing a stitch library see Editing a user stitch library.

**Duplicating a user stitch library**

1. To duplicate a user library, select one of the libraries from the User libraries tab and then **Duplicate**.

2. The Create new User Stitch Library dialog opens

   Name contains a generated name. If desired, type in a different name. The combination of name and namespace must be unique as these are used for the alias that is referenced from a .knt2 file. It is **NOT** possible to change the name of a stitch library at a later date as this would invalidate the alias.

   Namespace defaults to the current namespace value. It is **NOT** possible to change this value as this would invalidate the alias.

   Description is copied from the original library. If desired this text can be edited. It is possible to edit it later.

   Language is copied from the original library. This is used to identify non-english libraries to supress warnings about non-english characters that would cause problems if parsing using the text to chart feature. If desired select another language. It is possible to edit it later.

   Folder defaults to the home directory. To select a different directory use the Browse button.

   File name contains a generated default name. If desired, type in a different file name. The file extension must be ".smlib".
3. The Stitch Library dialog opens ready for editing. For details of editing a stitch library see Editing a user stitch library.

**Editing a user stitch library**

1. To edit a user library, select one of the libraries from the User libraries tab and then **Edit/View**.

2. The Edit Stitch Library dialog opens.

   Both description and language can be edited.

   There are two views of the stitch library; the table view and palette view. Swap between the views by selecting the appropriate tab.

   In the table view, the visible stitches can be filtered and the width of the columns adjusted. See Viewing a stitch library for more details

   Either view can be used for either editing an existing stitch or adding a custom stitch. The palette view also allows for the editing of palette drawers.
3. To edit an existing stitch either double click on the stitch or select the stitch and then select **Edit** from the tool bar.

The Edit Stitch dialog opens ready to edit the selected stitch type.

The following explains the different values and how they are used by the Knitting Chart Editor:

- **Consumes this many stitches** - this is the number of stitches that need to be on the needle in order to work this stitch. This is used when generating a chart from written input and also to validate charts. See Validating charts for more details. *For stitches defined in the Stitchmastery libraries it is not possible to edit this value as it forms part of the basic stitch definition.* The value can be edited for custom stitches added to the library.

- **Produces this many stitches** - this is the number of stitches that will be on the needle after this stitch is worked. It is used to calculate the stitch count when generating output text and also to validate charts. See Validating charts for more details. *For stitches defined in the Stitchmastery libraries it is not possible to edit this value as it forms part of the basic stitch definition.* The value can be edited for custom stitches added to the library.

- **Name** - used to generate the initial text for the key entry, except when 'Display string' is defined and then 'Display string is used instead.

- **Abbreviation** - used for the written output, except when 'Display string' is defined and then 'Display string is used instead.

- **Display string** - an optional text that is used for the key and written output when the desired output text has a format that would not be parsed correctly. For example, 'sl1, k1, psso' has got commas in its name. Hence the parser would 'misread' this as 3 different stitches instead of 1. Another example is '(k1, p1, k1) in 1 stitch'. Here the brackets and commas would again confuse the parser.

- **Long description** - can be used in key entries if desired.

- **Mirror** - used by the Knitting Chart Editor to identify the stitch that is the mirror image of a stitch. Used by the 'Flip selection vertically' feature so that left leaning cables are flipped to right leaning cables, etc.

- **Wrong side** - used by the Knitting Chart Editor to identify the stitch that is the equivalent stitch on a wrong side row. Hence a purl stitch on a right side row is a purl, but a purl stitch drawn on a wrong
side row is a knit stitch. This is used to generate the text for the key and also to generate correct written instructions for wrong side rows. Also to parse written instructions correctly when generating a chart.

- **Appearance** - shows the appearance of the stitch in both the chart and key. Select Edit Appearance to see more details.

- **Drawer** - shows the name of the Palette drawer where the stitch can be found.

Both Name and Abbreviation are recognised by the parser when parsing written instructions in order to generate a chart. See Working with Text Input for more information. For libraries that have language set to English, the name and abbreviation values are checked to ensure that they can be parsed correctly. If not, then a warning message is displayed.

4. To change the appearance of a stitch select the **Edit Appearance** button. The Edit Appearance dialog opens.

The Edit Appearance dialog allows you to change the symbol, the foreground and background colours of the stitch as well as the number of columns that the stitch will take up on the chart.

The Knitting Chart Editor allows you to select symbols from any font installed on your machine, in addition to 6 StitchMastery fonts that are embedded in the software. Details of the 6 StitchMastery fonts and their symbols can be found on the StitchMastery website at www.stitchmastery.com/stitchmastery-knitting-fonts-collection

5. Select the font to be used. The dialog will display all of the symbols for the selected font.

To change the symbol, first select **Clear** to clear all symbols from the stitch. Then either select the symbol directly or enter its unicode into the unicode text box. To find out the unicode for a particular symbol, move the mouse over the symbol and let it hover. A tooltip will appear displaying the unicode. In the example image below, the decrease symbol has unicode \u0055.

If you make a mistake when adding symbols, you can press the **Clear** button to start over again.
Press OK to finish editing the appearance of the stitch.

6. (Optional) If the stitch type being edited has previously had edits applied but is not a custom user stitch, click Revert to System Settings to remove all user edits and revert to the original values for that stitch type.

7. Select OK to finish editing the stitch.

8. To add a custom stitch when in the table view, select New → Stitch from the tool bar.

   To add a custom stitch when in the palette view, first select the drawer where you want to place the new stitch, then select New → Stitch from the tool bar.

   A new stitch with default / blank values and a generated default name is created and the Edit Stitch dialog opens ready to edit the new stitch.

9. To duplicate a stitch first select the stitch to be copied, then select Duplicate from the tool bar.

   A copy of the stitch is created with a generated name is created and the Edit Stitch dialog opens ready to edit the duplicated stitch.

10. In the palette view stitches can be moved around in drawers and to an adjacent drawer by selecting Move Down and Move Up from the tool bar. These commands only move the selected stitch one position at a time. To move a stitch to another drawer it is often quicker to select Edit and then choose a new Drawer.

11. When in the palette view, a drawer can be edited by either double clicking on the drawer or by selecting the drawer and then Edit from the tool bar.

12. The Edit Drawer dialog opens ready to edit the selected drawer.

   ![Stitch Library
   The name of the drawer can be editted and a description added. Also the drawer can be either hidden or pinned open.

13. Select OK to finish editing the drawer.

14. Select OK in all dialogs to finish editing the stitch library and to save changes.

**Removing a user stitch library**

1. To remove a user library, select one of the libraries from the User libraries tab and then Remove.
The alias for the user library is removed from the list of user libraries and is no longer available for use by chart diagram files. The user library file is not changed.

**Importing a user stitch library**

1. To import a user library, select the User libraries tab and then **Import**.

2. The Import User Stitch Library dialog opens.

3. Select **Browse** to find the stitch library file. Once a file is selected, the name, namespace, description and language values are retrieved from the stitch library and displayed.

4. Select **OK** to import the stitch library file.

   An alias is added to the list of user stitch libraries pointing to the imported file. The imported user library is open for editing.
Upgrading a version 1 stitch library

If version 1 Stitchmastery has previously run on the machine, then a version 1 stitch library will be present. In this case, Stitchmastery displays an option on the Stitch Libraries preferences page to upgrade that library to a version 2 format library. It is likely that the version 1 file has already been upgraded to version 2 format as prompts to do so are displayed when Stitchmastery starts and when a version 1 chart file (i.e., a file with a '.knit file extension) is saved to the version 2 format. It is possible to create a fresh version 2 library from the version 1 file by following these steps:-


2. The Upgrade from Version 1 to Version 2 dialog opens displaying the initial 'Welcome to Upgrading' page.

3. Select Next.

4. If the 'namespace' preference value has not yet been set, then the Configure Namespace page is displayed.

5. Enter an appropriate namespace and then select Next.

6. The Upgrade page is displayed.
7. Edit the name if desired. Also select the folder and file name for the new library file.

8. Select Finish to create the version 2 format stitch library file and create a new stitch library alias.

The new stitch library will contain customised stitches from the version 1 library and can be used by version 2 chart diagram files.

**Setting a stitch library as the 'active' stitch library**

In order to be able to use a stitch library it needs to be set as the 'active' stitch library on a chart diagram file. Then, when the chart diagram file is opened, the palette will be filled with stitches from the 'active' stitch library. This only applies for version 2 (.knt2) format chart files. Version 1 chart files (.knit) will always use the version 1 stitch library and the stitch library cannot be changed.

The 'active' stitch library can be selected when a chart diagram file is created.

If a chart diagram file exists already and you want to change the 'active' library then follow these steps:

1. Open the chart diagram file.

2. Select **Diagram → Edit Diagram Properties** from the main menu.

3. In the Edit Diagram Properties dialog, select the Stitch Library and Text Templates tab.

4. From the Stitch Library drop down menu, select the desired stitch library.

5. Select **OK**.

If the system library that the new 'active' extends is different from that of the existing library then any 'system' stitches in the chart file are swapped out. In addition the palette contains stitches from the new 'active' library.

**Editing a user stitch library via the Palette**

When a chart diagram file is open and the current stitch library for that file is a user stitch library then it is possible to edit the user library via the Palette.
Working with the Stitch Library

Note that this only applies to chart diagram files created in version 2, that is those with a `.knt2` file extension. It does not apply to files created in version 1, that is those with a `.knit` file extension. The editing is limited to the current user library. To create a user library or edit other libraries, go to Viewing and editing stitch libraries via Preferences.

To edit a user library via the palette:-

1. Right mouse click (Windows) or Control mouse click (Mac) on any entry in the palette. In the example below the right / control click takes place on a stitch entry. A popup menu appears with a single entry "Customize...".

2. Select Customize... The Edit Stitch Library dialog opens.

3. Follow the steps given for editing a user stitch library as desired.

4. Select OK to finish editing the stitch library. The stitch library is now updated and you will see the changes reflected in the palette.
Chapter 4. Working with Stylesheets

About Stylesheets

Many of the preferences and options controlling both the appearance of the charts and the format of the written instructions have been grouped together into a series of stylesheets.

There are three categories of stylesheets:-

1. Appearance stylesheets. These contain options that control the appearance of the charts and key. Options include the size and colour of the grid, highlighting lines, annotations for repeated stitches, the default font for text, etc.

2. Written stylesheets. These contain options for the written instructions such as if and when stitch counts should be included, if rows/rounds should be condensed etc.

3. Text template stylesheets. These contain templates that are used to generate text for both key entries on the chart and written instructions.

An overview of Stitchmastery stylesheets is shown below.

For details of Stitch Libraries see About Stitch Libraries 'Stitchmastery' stylesheets for each of the above categories are provided and can be used as the defaults. However, if a user would like to customise any of the above options then 'user' versions of any of the stylesheets can be created. Chart files reference stylesheets indirectly through aliases that are stored as preferences. The stylesheets themselves are also
stored as preferences. Using an alias means that stylesheets can easily be shared by exporting them to a file. This file can be transferred to other computers and users by 'importing' the stylesheets from the file.

A version 2.0 chart diagram file (a '.knt2' file) has references to both a stitch library and stylesheets. When a chart diagram file is created it is assigned both a stitch library and three stylesheets; an Appearance stylesheet, a Written stylesheet and a Text templates stylesheet. See below for an example.

By changing the stylesheets both chart and written instructions can be customised as shown in this example:

By also changing the stitch library as well as the text template stylesheet both the chart and written instructions can be translated to another language as the example below shows.
Making changes with stylesheets

When a chart diagram file is first created the appearance of the chart and key are governed by the appearance stylesheet at that time.

Stylesheet options that affect the appearance of the chart can also be selectively overridden from within the chart diagram. This does not affect the stylesheet in any way. So, if for example you need to highlight a row on the chart, then the font for that row number can be changed without having to edit the stylesheet.
Editing a stylesheet or changing the reference to a different stylesheet does not have an immediate effect on the appearance. The reason for this is that style sheets can be edited independently of the chart diagram files and appearance options can be selectively overridden. By not automatically changing a chart's appearance, the user can have confidence that the appearance of a chart will remain unchanged even if several weeks have passed since the file was last edited and other edits have been made to the stylesheet. In the example below the appearance stylesheet has been edited to change the colour of the grid. However, the colour of grids in any chart remain unchanged until an appearance stylesheet is explicitly 'applied' to it.

Once a stylesheet change is made, it can then be 'applied' to the charts and key as shown here:-

The text of key entries is also not updated automatically. The text for key entries is generated automatically either when the chart diagram is created or for when a stitch is used in a chart for the first time and an entry is added to the key. The text is then only changed as a direct result of an action by the user, such as a manual edit of the text or using the 'Refresh Key text' action. The example below shows a newly created chart. As the chart is set for circular knitting, the key entry text is generated using the 'Circular' template.
Below is the same chart after the key text for 'knit' has been manually edited to change it to the German for 'knit'. Note that this has only changed the text. Because neither the template stylesheet nor the stitch library have been changed, Stitchmastery still recognises this as a 'knit' stitch and generates written instructions in English as before.

Yet when the stitch library and text template are changed the key entry text is still not updated. By not changing automatically, any manual edits made to the text are preserved. On the other hand, written instructions are always regenerated every time that a chart diagram file is either opened or edited. Thus any changes to the stylesheets have an immediate effect on the written output as is illustrated here;
Working with Stylesheets

1. Open the Preferences dialog. See Preferences for more details.

2. Select **Knitting Chart Editor** → **Stylesheets** to see all the stylesheets that are currently known to Knitting Chart Editor.

**Viewing and editing stylesheets**

To see changes to the key the key text must be explicitly ‘refreshed’.

Runden 1 - 4: Rechts.

Stitch library and stylesheets edited. Chart is unchanged. Written instructions are generated afresh and reflect changes.

Explicitly ‘refresh’ key text to reflect changes.

Runden 1 - 4: Rechts.
Working with Stylesheets

There are three kinds of stylesheets; Appearances, Written and Text Templates. Currently there are three Stitchmastery stylesheets; one for each of the three kinds of stylesheet. See About Stylesheets for more details of the different kinds of stylesheets and their roles.

Initially there will be no user stylesheets. See Creating a user stylesheet to find out how to create a user stylesheet.

Default stylesheets: when creating a new chart diagram file, its stylesheets are set to the current default stylesheets unless another stylesheet is specifically chosen. The stylesheets of a chart diagram file can be changed later.

**Viewing a Stitchmastery stylesheet**

1. To view a Stitchmastery stylesheet, select one of the stylesheets and then **Edit/View**.

2. The appropriate Stylesheet dialog opens. As this is a Stitchmastery stylesheet that is being viewed the dialog is in 'Read Only' mode.
3. For an explanation of the different stylesheets and how they are used by the Knitting Chart Editor see About Stylesheets.

**Creating a user stylesheet**

1. To create a user stylesheet, select one of the stylesheets and then **Duplicate**.

2. If this is the first time that you have created a user stylesheet or stitch library and the 'Namespace' value has not yet been set, the Configure Namespace dialog will prompt you to enter a 'namespace' value.

   The 'namespace' is an identifier that is used to label the stitch libraries and stylesheets that you create. It is important to choose a value that is unique to you to make it easier to share stitch libraries and stylesheets with others. For more information on choosing a namespace see What's a namespace?.

   It is possible to change the namespace later but it is not possible to apply such a change to any existing stylesheets or stitch libraries.

   Enter a value for namespace and then select **OK**.

   ![Configure Namespace dialog](image)

3. The appropriate Stylesheet dialog opens. The example below shows a Text Templates stylesheet.

   Name contains a generated name. If desired, type in a different name. The combination of name and namespace must be unique as these are used for the alias that is referenced from a .knt2 file. It is **NOT** possible to change the name of a stylesheet at a later date as this would invalidate the alias.

   Namespace defaults to the current namespace value. It is **NOT** possible to change this value as this would invalidate the alias.

   Description is copied from the original stylesheet. If desired this text can be edited. It is possible to edit it later.

   For Text Templates stylesheet only: Language is copied from the original stylesheet. This is used to correctly translate numbers into words if requested in a template. If desired select another language. It is possible to edit it later.
For details of editing the remaining values for each stylesheet see Editing a user stylesheet.

**Setting a stylesheet as the 'active' stylesheet**

In order to be able to use a stylesheet it needs to be set as one of the 'active' stylesheets on a chart diagram file. This only applies for version 2 (.knt2) format chart files. Version 1 chart files (.knit) do not use stylesheets.

The 'active' stylesheets can be selected when a chart diagram file is created.

If a chart diagram file exists already and you want to change the 'active' stylesheets then follow these steps:

1. Open the chart diagram file.
2. Select **Diagram → Edit Diagram Properties** from the main menu.
3. In the Edit Diagram Properties dialog, select the appropriate tab that corresponds to the stylesheet to be changed.
4. From the drop down menus, select the desired stylesheets.
5. If the stylesheet is an Appearance stylesheet, select the **Apply** button to apply the settings from the Appearance stylesheet to the chart diagram file.
6. Select **OK**.

**Editing a user Appearance stylesheet**

1. To edit a user Appearance stylesheet, select the stylesheet and then **Edit/View**. Stitchmastery stylesheets can not be edited.
2. The Appearance Stylesheet dialog opens ready for editing.
Name and namespace cannot be edited as this would invalidate the alias.

Description can be edited.

The following explains the different values and how they are used by the Knitting Chart Editor:

- **Default Font** - used for all text on the chart and key except for the chart and key titles. This font is assigned either when a chart diagram is created or when an element is added to the chart, for example when a row or column is added to a chart or an edit causes a new entry to be added to the key. The font can be overridden by using the Edit Font command.

- **Default Font (Key and Chart titles)** - used as above but for the chart and key titles only.

- **Stitch symbol colour automatically contrasts with background colour** - if this is not set then the symbol colour remains black even if the background colour is dark. If set, then when the background colour is dark, the symbol colours switches automatically to white. Note that this does not apply to stitches that have custom foreground and background colours set.

- **Grid** (click either on the right pointing triangle or on More on grid ... to expand the Grid display):
  
  - **Grid Cell Width and Height** - the size of each chart cell in pixels. This size is also used for the key entry boxes.
  
  - **Grid Colour** - used for the grid on all charts and for the outline of boxes in the key.

- **Grid highlighting** (click either on the right pointing triangle or on More on grid highlighting... to expand the Grid highlighting display):
  
  - **Highlight Grid Lines** - used to turn grid highlighting on and off.

  - **Number of Columns / Rows between Highlighted Grid Lines** - use to control the frequency of the highlighting lines if highlighting is turned on.

  - **Highlight Colour** - used as the colour of the highlighting if grid highlighting is set.
• **Annotating repeated stitches** (click either on the right pointing triangle or on More on annotations... to expand the Annotating repeated stitches display):

In order to show annotations and be able to edit the annotations values, select **Display Annotations**.

The **Minimum number of stitches** defines the number of similar stitches that must be next to each other before an annotation is displayed. Any 'stretch' less than this number is not annotated. This number must be between 3 and 9.

Select **Number background transparent** to have the number drawn with a transparent background. If not selected, the number is drawn with a white background. A transparent background is useful for a colourwork chart, whilst a white background is best if the number is in front of symbols and grid lines.

If **Automatically contrasts with yarn/colour** is selected then, if the background colour is dark the number colour swaps to white. Note that this only works if **Include colour in written instructions** is also selected.

The font for the numbers can be selected.

There are four options for the horizontal positioning of the annotation number within the stretch of repeated stitches; **Left**, **Right** and **Centre** position in the number to the left, right or centre of the stretch respectively. **Beginning** places the number at the beginning of the stretch. That is, for right side rows and for charts worked in the round, the number is always on the right hand side, whilst it is on the left for wrong side rows.

The vertical position can be set to either **Top**, **Bottom** or **Middle**

Once the number's horizontal and vertical positions have been set, its exact location can be fine tuned by editing the **Gap at sides** and **Gap at top/bottom** values. However, these values have no effect if the number is centred.

• **Borders** (click either on the right pointing triangle or on More on borders... to expand the Borders display):

All the values here are used when creating a Border for the first time. To edit the values for any Border, once created, see Editing a Border.

**Border display text** is the default text that is the key entry when a border is first created.

**Border position**, **Border colour**, **Line style** and **Width of border** should all be self-explanatory.

**Move border inwards** allows for a border to be shifted inwards (positive values) or outwards (negative values) from the centre line of the grid. This can be useful where adjoining or overlapping borders would otherwise mask each other. By shifting on or more of the borders, both of them can be made visible. The sides of each border can be moved individually.

All of these values can be edited for individual borders once they are created. See Editing a Border.

3. Select **OK** to finish editing the stylesheet.

**Editing a user Written stylesheet**

1. To edit a user Written stylesheet, select the stylesheet and then **Edit/View**. Stitchmastery stylesheets can not be edited.
2. The Written Stylesheet dialog opens ready for editing.

Name and namespace cannot be edited as this would invalidate the alias.

Description can be edited.

The following explains the different values and how they are used by the Knitting Chart Editor:

- Capitalise row/round contents - if set, always capitalises the written instructions for example 'Row 1: K1, p1,k2' instead of 'Row 1: k1, p1,k2'.

- Ignore hidden rows - if set and rows are hidden in a chart, then the rows are excluded from the Output Text View as well as being ignored when a chart is being validated.

- Condense rows/rounds when possible - if set, Stitchmastery looks for patterns of rows/rounds that are repeated. If not, then each row/round is written out in detail regardless of whether it is similar to a previous row/round.

- Include stitch count - choose from three different options for whether a stitch count should be displayed. Note that this is the total stitch count for a row/round.

- Include RS/WS labels for rows - choose from four different options for whether RS/WS labels should be displayed. This option does not apply for charts set to 'round'.

3. Select OK to finish editing the stylesheet.

**Editing a user Text Templates stylesheet**

1. To edit a user Text Templates stylesheet, select the stylesheet and then Edit/View. Stitchmastery stylesheets can not be edited.

2. The Text Templates Stylesheet dialog opens ready for editing.

Name and namespace cannot be edited as this would invalidate the alias.

Description and Language can both be edited.
Text templates allow users to control the content of all text that is automatically generated by the software. Templates combine text with variables and (rarely) template control words. Variables are identified by the dollar sign and enclosing parentheses and are replaced with the appropriate text value when the text is generated. In some cases a variable represents the output from a different template. Each template has a 'context' for when it is used and the variables that are appropriate for the template are determined by its context.

Template control words are identified by a percentage sign and have a specific meaning that controls the text generated. See Text Templates for more information on using control words.

The following describes how to edit a template. For more information on each template, when it is used and the variables that can be entered for each template see Text Templates

a. In the Text Templates Stylesheet dialog, templates are grouped together under different tabs. Change tabs until you find the relevant template. Select the template to be edited.

b. A preview of the selected template is displayed in the Preview box.
c. Select **Edit**. The Edit Key Entry Template dialog appears:

![Edit Key Entry Template](image)

d. Within the Pattern text box you can type any text. Text will appear unchanged in the key entry text. This includes 'white space' such as spaces and tabs at the beginning and end of the template as well as new lines within the template.

e. Select **Insert Variable** to insert a variable into the text.

f. A list of variables is displayed. Select a variable to display a panel that shows the variable definition.

  Double click a variable in the list to cause it to be added to the template.

g. Below is an example where both the abbreviation and displayString variables are used, separated by a hyphen:
h. Select **OK** in all dialogs to finish editing the stylesheet and to save changes.

i. Once the template is saved, all key entries for circular charts that use this Text Templates stylesheet will use it to generate the key entry text as shown below:-

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>p</td>
<td>purl</td>
</tr>
<tr>
<td>k</td>
<td>kilt</td>
</tr>
<tr>
<td>d</td>
<td>slip</td>
</tr>
</tbody>
</table>

Note that, for key entries, the key entry text is only generated when a stitch is added to the key as a result of editing or if the key entry text is specifically refreshed. See ... for details of how to refresh key entries.

---

**Removing a user stylesheet**

1. To remove a user stylesheet, select one of the user stylesheets and then **Remove**. Stitchmastery stylesheets cannot be removed.

   The alias for the user stylesheet is removed from the list of stylesheets and is no longer available for use by chart diagram files.

---

**Exporting user stylesheets**

1. To export user stylesheets, select **Export**.

   2. The Export Stylesheets dialog opens.
Working with Stylesheets

3. Select **Browse** to select a folder and file that will contain the exported stylesheets. The exported file will have a `.epf` file extension. The file can either be a new file that will be created as the result of the export or an existing file that will be overwritten.

4. Select the stylesheets that you wish to export.

5. Select **OK** to export the stylesheets.

   The selected stylesheets are added to the file.

6. If **Overwrite existing files without warning** is not selected, a dialog is displayed warning that the file already exists.

   Select **Yes** to overwrite the file or **No** to cancel the export.

**Importing user stylesheets**

1. To import user stylesheets, select **Import**.

2. The Import Stylesheets dialog opens.
3. Select **Browse** to find the stylesheets file. The file will have a .epf file extension and is created by exporting stylesheets using the **Export**. Once a file is selected, the stylesheets within the file are displayed.

4. Select the stylesheets that you wish to import.

5. Select **Set imported stylesheets to read only** if you would like to import stylesheets that you do not intend to edit. This would be a good option if you are importing stylesheets published by someone else. An example would be if a publisher has produced stylesheets that can be used for submissions.

6. Select **OK** to import the stylesheets.

   The selected stylesheets are added to the list of stylesheets in preferences.
7. If **Overwrite existing stylesheets without warning** is not selected, a dialog is displayed warning that a stylesheet with the same name and namespace already exists in your preferences.

Select **Yes** to overwrite the stylesheet with the version in the file or no to not import that particular stylesheet and leave it as it is.

## Text Templates

Text templates allow users to define the content of all text that is automatically. It does this by using a combination of text and variables and (rarely) template control words. Variables are identified by the dollar sign and enclosing parentheses and are replaced with the appropriate text value when the text is generated. In some cases a variable represents the output from a different template.

As an example, when the text for the written instructions for a row are generated the 'Row Label' template is used to generate the label for the row. The default definition for the 'Row Label' template is:-

Row ${ID}:

${ID} is a variable that represents the identifier for the row. Hence for row 1, the identifier is '1' and the generated row label is;-:

Row 1:

If the 'Row Label' template was edited to:-

$${ID}$. row:

then the generated row label would instead be:-

1. row:

Details of all of the templates and of the valid variables for each template are listed below.

## Template Control Words

In order to give more control over the text for key entries template control words are available. Template control words begin with %. To explain how they work here is an example:-

```text
%if text1 == text2 %endif
	'template text 1'
%else
	'template text 2'
%endelse
```

The words %if, %endif, %else and %endelse are control words.

Between %if and %endif there must be two text elements separated by two equals signs. If the two text elements are equal after any variable text has been substituted, then the text on the following line before
the %else statement is used as the template text. Otherwise, the text on the line following %else and before %endelse is used.

Below is an example where the %if .. %endif .. %else .. %endelse syntax is used to simplify the key entries for stitches when both the right row and wrong side values are the same:-

![Image](image_url)

**Template Details**

The following tables document of all of the templates available with details of the variables that are valid for each template. Some examples of how the templates are used are also shown.

**Table 4.1. Key Text**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Key title</td>
<td>Key title</td>
<td>none</td>
<td>Key</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Legende</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Stitch entry flat</th>
<th>Stitch key entry in flat mode</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>${abbreviation} - abbreviation of stitch</td>
<td>RS: knit WS: purl</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${displayString} - display string of stitch. If not defined, then name of stitch</td>
<td>RS - knit, WS - purl</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${longDescription} - long description of stitch</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>${WSabbreviation} - abbreviation of WS stitch</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>${WSdisplayString} - display string of WS stitch. If not defined, then name of WS stitch</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>${WSlongDescription} - long description of WS stitch</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
<td>Variables</td>
<td>Examples</td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------------------</td>
<td>-----------------------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Stitch entry circular</td>
<td>Stitch key entry in circular mode</td>
<td>${abbreviation} - abbreviation of stitch</td>
<td>knit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${displayString} - display string of stitch.</td>
<td>k - knit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If not defined, then name of stitch</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>${longDescription} - long description of</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>stitch</td>
<td></td>
</tr>
<tr>
<td>Yarn alias</td>
<td>Yarn key alias format</td>
<td>${alias} - alias of yarn if defined</td>
<td>(MC)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>MC :</td>
</tr>
<tr>
<td>Yarn entry</td>
<td>Yarn key entry</td>
<td>${name} - name of yarn</td>
<td>Green (MC)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${yarnAlias} - output from yarn alias</td>
<td>MC : green</td>
</tr>
<tr>
<td></td>
<td></td>
<td>template</td>
<td></td>
</tr>
</tbody>
</table>

**Table 4.2. Row Labels**

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row label</td>
<td>Label for a single row</td>
<td>${ID} - the identifier of the row</td>
<td>Row 1:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Reihe 1:</td>
</tr>
<tr>
<td>Row label RS</td>
<td>Label for a single row with RS label</td>
<td>${ID} - the identifier of the row</td>
<td>Row 1 (RS):</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Row 1 (Right Side):</td>
</tr>
<tr>
<td>Row label WS</td>
<td>Label for a single row with WS label</td>
<td>${ID} - the identifier of the row</td>
<td>Row 1 (WS):</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Row 1 (Wrong Side):</td>
</tr>
<tr>
<td>Round label</td>
<td>Label for a single round</td>
<td>${ID} - the identifier of the round</td>
<td>Round 2:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>2. Runde:</td>
</tr>
<tr>
<td>Row all RS label</td>
<td>Label for a row plus all RS rows</td>
<td>${ID} - the identifier of the first row</td>
<td>Row 1 and all RS rows:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Row 1 and all right side rows:</td>
</tr>
<tr>
<td>Row all WS label</td>
<td>Label for a row plus all WS rows</td>
<td>${ID} - the identifier of the first row</td>
<td>Row 2 and all WS rows:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Row 2 and all wrong side rows:</td>
</tr>
</tbody>
</table>
### Working with Stylesheets

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Round all even label</td>
<td>Label for a round plus all even rounds</td>
<td>${ID} - the identifier of the first round</td>
<td>Round 2 and all even-numbered rounds:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Round 2 and all even rounds:</td>
</tr>
<tr>
<td>Round all odd label</td>
<td>Label for a round plus all odd rounds</td>
<td>${ID} - the identifier of the first round</td>
<td>Round 1 and all odd-numbered rounds:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Round 2 and all odd rounds:</td>
</tr>
<tr>
<td>Row range label</td>
<td>Label for a range of rows</td>
<td>${firstID} - the identifier of the first row in the range</td>
<td>Rows 1-4:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Reihen 1 - 4:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${lastID} - the identifier of the last row in the range</td>
<td></td>
</tr>
<tr>
<td>Round range label</td>
<td>Label for a range of rounds</td>
<td>${firstID} - the identifier of the first round in the range</td>
<td>Rounds 1-4:</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Runden 1 - 4:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${lastID} - the identifier of the last round in the range</td>
<td></td>
</tr>
</tbody>
</table>

#### Table 4.3. Repeats

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Asterisk repeat</td>
<td>Asterisk repeat</td>
<td>${repeatContents} - the text for the stitches inside the repeat</td>
<td>*k2, p2; work from *</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>*2 re, 2 li; ab * arbeiten</td>
</tr>
<tr>
<td>Round bracket repeat</td>
<td>Round bracket repeat</td>
<td>${repeatContents} - the text for the stitches inside the repeat</td>
<td>(k1, p1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>{k1, p1}</td>
</tr>
<tr>
<td>Implicit repeat</td>
<td>Implicit repeat</td>
<td>${repeatContents} - the text for the stitches inside the repeat</td>
<td>(k1, p1)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>{k1, p1}</td>
</tr>
<tr>
<td>Row repeat</td>
<td>Row repeat</td>
<td>${repeatRowID} - the identifier for the row to be repeated</td>
<td>repeat row 4</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Reihe 4 wdh.</td>
</tr>
<tr>
<td>Round repeat</td>
<td>Round repeat</td>
<td>${repeatRowID} - the identifier for the round to be repeated</td>
<td>repeat round 4</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Runde 4 wdh.</td>
</tr>
</tbody>
</table>
### Working with Stylesheets

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rows repeat</td>
<td>Rows repeat</td>
<td><code>${firstRepeatRowsID}</code> - the identifier for the first row to be repeated</td>
<td>repeat rows 4 - 7</td>
</tr>
<tr>
<td></td>
<td></td>
<td><code>${lastRepeatRowsID}</code> - the identifier for the last row to be repeated</td>
<td>Reihen 4 - 7 wdh.</td>
</tr>
<tr>
<td>Rounds repeat</td>
<td>Rounds repeat</td>
<td><code>${firstRepeatRowsID}</code> - the identifier for the first round to be repeated</td>
<td>repeat rounds 4 - 7</td>
</tr>
<tr>
<td></td>
<td></td>
<td><code>${lastRepeatRowsID}</code> - the identifier for the last round to be repeated</td>
<td>Runden 4 - 7 wdh.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Times 1 qualifier</td>
<td>Times 1 qualifier</td>
<td>none</td>
<td>once</td>
</tr>
<tr>
<td>Times 2 qualifier</td>
<td>Times 2 qualifier</td>
<td>none</td>
<td>twice</td>
</tr>
<tr>
<td>Times qualifier</td>
<td>Times qualifier</td>
<td><code>${repeatCount}</code> - total times that a repeat is worked displayed as digits</td>
<td>5 mal</td>
</tr>
<tr>
<td></td>
<td></td>
<td><code>${repeatCountWords}</code> - total times that a repeat is worked displayed as words</td>
<td>five times</td>
</tr>
<tr>
<td>Maths format times qualifier</td>
<td>Maths format times qualifier</td>
<td><code>${repeatCount}</code> - total times that a repeat is worked displayed as digits</td>
<td>x 5</td>
</tr>
<tr>
<td></td>
<td></td>
<td><code>${repeatCountWords}</code> - total times that a repeat is worked displayed as words</td>
<td>x five</td>
</tr>
</tbody>
</table>

### Table 4.4. Row Contents

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stitch template regular single</td>
<td>Stitch regular format for single stitch - for all stitches except knit and purl</td>
<td><code>${stitchDisplayString}</code> - display string if defined, else abbreviation if defined, else stitch name</td>
<td>knit into fb</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
<td>Variables</td>
<td>Examples</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Stitch template condensed single</td>
<td>Stitch condensed format for single stitch - for knit and purl</td>
<td>${stitchDisplayString} - display string if defined, else abbreviation if defined, else stitch name</td>
<td>k1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchAbbreviation} - abbreviation if defined, else stitch name</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchName} - stitch name</td>
<td></td>
</tr>
<tr>
<td>Stitch template regular</td>
<td>Stitch regular format for multiple stitches - for all stitches except knit and purl</td>
<td>${stitchDisplayString} - display string if defined, else abbreviation if defined, else stitch name</td>
<td>knit into fb</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchAbbreviation} - abbreviation if defined, else stitch name</td>
<td>kfb</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchName} - stitch name</td>
<td>1/1 RC x five</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${numberLabel} - number of the stitch displayed as digits</td>
<td>(1/1 RC) x 5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${numberWordLabel} - number of the stitch displayed as words</td>
<td></td>
</tr>
<tr>
<td>Stitch template condensed</td>
<td>Stitch condensed format for multiple stitches - for knit and purl</td>
<td>${stitchDisplayString} - display string if defined, else abbreviation if defined, else stitch name</td>
<td>k5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchAbbreviation} - abbreviation if defined, else stitch name</td>
<td>k 5</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchName} - stitch name</td>
<td>knit 5</td>
</tr>
<tr>
<td>Name</td>
<td>Description</td>
<td>Variables</td>
<td>Examples</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Stitch with number and yarn label</td>
<td>Stitch with number and yarn - used when colour included in written instructions</td>
<td>${stitchTemplateOutput} (\text{k5 in MC}) - output from one of the stitch templates</td>
<td>5 rechts</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${yarnLabel} - yarn/colour identifier; alias if defined, else name</td>
<td>2 links rot</td>
</tr>
<tr>
<td>Stitch with number label</td>
<td>Stitch with number only (no yarn)</td>
<td>${stitchTemplateOutput} (\text{k5}) - output from one of the stitch templates</td>
<td>2 links</td>
</tr>
<tr>
<td>Number of stitches in a yarn label</td>
<td>Number of stitches in a yarn (no stitch)</td>
<td>${yarnLabel} - yarn/colour identifier; alias if defined, else name</td>
<td>5 MC, 2 CC</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${numberLabel} - number of the stitch displayed as digits</td>
<td>five green, 2 red</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${numberWordLabel} - number of the stitch displayed as words</td>
<td>A2, B3, A2</td>
</tr>
<tr>
<td>Work all stitches</td>
<td>Work all stitches in a row - used when all the stitches in a row are the same</td>
<td>${stitchDisplayString} - display string if defined, else abbreviation if defined, else stitch name</td>
<td>knit</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchAbbreviation} - abbreviation if defined, else stitch name</td>
<td>k to end</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchName} - stitch name</td>
<td>knit to end</td>
</tr>
<tr>
<td>Work stitch row prefix</td>
<td>Work stitch row prefix - used when all stitches are the same but in different colours</td>
<td>${stitchDisplayString} - display string if defined, else abbreviation if defined, else stitch name</td>
<td>work knit as follows;</td>
</tr>
</tbody>
</table>
### Working with Stylesheets

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variables</td>
<td></td>
<td>${stitchAbbreviation} - abbreviation if defined, else stitch name</td>
<td>k all stitches as follows,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchName} - stitch name</td>
<td></td>
</tr>
<tr>
<td>Using yarn row prefix</td>
<td>Using yarn row prefix - used when stitches are different but in the same colour</td>
<td>${yarnLabel} - yarn/colour identifier; alias if defined, else name</td>
<td>using MC, with green,</td>
</tr>
</tbody>
</table>

### Table 4.5. Stitch Count

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stitch count</td>
<td>Total number of stitches</td>
<td>${stitchCount} - total number of stitches in the row/round</td>
<td>(16 sts)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>(16 Maschen)</td>
</tr>
<tr>
<td>Stitch count singular</td>
<td>Stitch count when there is only 1 stitch</td>
<td>none</td>
<td>(1 st)</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>(1 Masche)</td>
</tr>
</tbody>
</table>

### Table 4.6. Row Format

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Variables</th>
<th>Examples</th>
</tr>
</thead>
<tbody>
<tr>
<td>Row/round format</td>
<td>Format of complete row/round</td>
<td>${rowLabelTemplateOutput}: k2, p2. (4 sts) - output generated by row/round label template</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>${rowContentsTemplateOutput}: k2, p2 (4 sts) - output generated for row/round contents</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>${stitchCountTemplateOutput} - output generated for stitch count</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 5. What's a namespace?

What's a namespace?

A namespace is a name that identifies you. It is used for labelling any stitch libraries or style sheets that you create. Having a namespace that is unique allows you to share files with others. Stitchmastery does not check or enforce this, so choose something that no-one else is likely to choose. If you are the owner of a domain name, this would be a good choice.

If you do not have an internet domain name then another possibility is to use an email address. Also many social media sites such as Twitter or Ravelry require you to have a unique username so another possibility would be to use the name of the social media site followed by your own username, for example, 'www.ravelry.com.funkyorange'.

Choose your namespace carefully. It is possible to change it later using Preferences → Knitting Chart Editor → Namespace. However, Version 2 chart files use both name and namespace to identify stitch libraries and style sheets. For this reason, it is not possible to change the namespace of stitch libraries or style sheets once they are created.
Chapter 6. Repeats and Borders

Repeats and Borders

Differences between Repeats and Borders

Borders can be used to highlight a repeat of stitches but can also be used to denote custom instructions. Examples include marking sections of the chart such as left section, centre section etc, indicating the starting row/round for different sizes, etc.

Repeats can have a border associated with them but this is optional. Borders are a purely visual tool that is visible on the chart only. Borders are not present in the written instructions that are output by the Knitting Chart Editor. On the other hand a Repeat is included in the internal model that the Knitting Chart Editor maintains and is used to generate written instructions that include the appropriate instructions for repeats.

Repeats

A Repeat is used to model a group of consecutive stitches in a row that are to be repeated and are used to generate written instructions that include repeats.

There are two categories of repeats; Explicit repeats and Implicit repeats.

Explicit Repeats

Explicit repeats are those that are explicitly added by the user using the **Place Stitches in Selection into a Repeat** command. Although they are usually not visible in the charts, explicit repeats can be selected and their properties edited.

Currently users can add two different types of repeats; 'Asterisks' and 'Round Brackets'.

Asterisks have the following format;-

```
*k, p ; repeat from *
```

whilst Round Brackets have this format;-

```
(k, p)
```

Repeats have an optional qualifier that is used to define the number of times that a repeat will be worked. There are two formats available;-

1. *k, p ; repeat from * 3 times
2. *k, p ; repeat from * x 3

Explicit repeats are not expanded when parsing from the written format to the chart. Hence in the above examples, the repeats are represented by two stitch cells on the chart regardless of however many times the repeat is worked.

Implicit Repeats

Implicit repeats are repeats that are automatically discovered by the Knitting Chart Editor and used to compact written instructions.
These repeats are of the 'Square Brackets' type and have the following format:-

\([k, p] \times 3\)

Square Bracket repeats are added to the written instructions by the Knitting Chart Editor when it discovers a repeat in the stitches in a row. For example in the following chart

![](chart_example.png)

the user has not added an explicit repeat to the chart but the alternate knit and purl stitches give an implicit repeat. Instead of generating written instructions of the form:-

Round 2: k, p, k, p, k, p.

the Knitting Chart Editor automatically adds an implicit repeat so that the instructions have the form:-

Round 2: \([k, p] \times 3\).

Implicit repeats are always expanded when parsing from the written format to the chart. In the above example, the implicit repeat of two stitches is repeated 3 times, hence this repeat is represented by six stitch cells on the chart regardless of however many times the repeat is worked. Implicit repeats can neither be selected nor their properties edited. The Square Bracket type is used to distinguish the implicit repeats from the explicit repeats when parsing in the Input Written Instructions View.

When exporting the written instructions the Square Brackets repeats are converted to the format for Round Brackets.

**Adding a new Repeat**

To place a group of stitches into a repeat;-  

1. Select the stitches (see Selection Tools). Stitches in the same row must be adjacent to one another.  

   Alternatively, one or more rows or charts can be selected. In that case, all of the stitches in the selected row(s) or chart(s) will be added to a repeat. If no selections are made, then all stitches in all of the charts will be added to a repeat.

2. On the main menu bar, select **Repeat > Place Stitches in Selection into a Repeat**. The Edit Repeat dialog opens.

3. Change properties as desired. Note that repeats can optionally have a border associated with them. The border is purely visual.

4. The number of repeats can either be a single number or numbers separated by commas. The latter can be used for charts where a repeat is worked a varying number of times.

5. Select **OK**.

6. The selected stitches will be placed into repeats. This happens on a per row basis so that there is a separate repeat for each row. All the stitches in the same row are placed into the same repeat and all repeats initially have the same properties. If a border is associated with the repeats then this is drawn around the stitches and an entry added to the key if needed. Current preference values (see Preferences) are used for the name, colour and line style of the border. These can be changed at any time by using the Edit Border dialog.
Removing a group of stitches from a Repeat

To remove a group of stitches from a repeat;-

1. Select the stitches (see Selection Tools).

   Alternatively, one or more rows or charts can be selected. In that case, all of the repeats in the selected row(s) or chart(s) will be removed. If no selections are made, then all the repeats in all of the charts will be removed.

2. On the main menu bar, select Repeat > Remove all Repeats from Stitches in Selection.

Editing a repeat or repeats

The qualifier for a repeat or repeats can be edited by following these steps;-

1. Select the repeats (see Selection Tools).

   The selection of the repeats will be displayed with a thin black rectangle around the repeat.

2. On the main menu bar, select Repeat > Edit Repeat(s).

3. Make the desired changes to the qualifier and select OK. The selected repeat(s) will be updated and the changes reflected in the written instructions.

Working with Borders

Borders can be placed around a stitch or group of stitches. An entry for the border is placed in the key. Borders can be drawn on any of the four sides (North, South, East, West) of the stitch cells or any combination. The border's name, colour and line style can all be customised.

Adding a new Border

To place a new border around a group of stitches;-

1. Select the stitches (see Selection Tools).

2. On the main menu bar, select Border > Place Border on Selected Stitches > All Sides / North Side only / South Side only ..... etc as appropriate.

3. A new border will be drawn around the stitches on the appropriate sides. Values from the current Appearance stylesheet (see Editing a user Appearance stylesheet) are used as initial values for the border. These can be changed at any time by using the Edit Border dialog.

Adding an existing Border

To place an existing border around a group of stitches;-

1. Select the stitches (see Selection Tools).

2. On the main menu bar, select Border > Place Existing Border on Selected Stitches (not visible if there are no borders yet). A sub menu will be dynamically created that lists all of the borders present. Select as appropriate.

3. The existing border will be drawn around the stitches.
Removing a Border from a group of stitches

To remove a border from a group of stitches;- 

1. Select the stitches (see Selection Tools).

2. On the main menu bar, select **Border > Remove Border from Selected Stitches** (not visible if there are no borders on stitches). A sub menu will be dynamically created that lists all of the borders present. Select as appropriate.

3. The border will be removed from the stitches.

Editing a Border

To change the properties of a Border;- 

1. Select the border entry in the key (see Selection Tools).

2. On the main menu bar, select either **Border > Edit Border Properties**. The Edit Border dialog opens.

3. Change properties as desired.

4. Select **OK**.

The name of the border can also be changed using direct editing as follows;- 

1. Select the border name label in the key (see Selection Tools). The label will show selection with a light blue background.

2. Click once anywhere on the label text. The label will change to an editable text box with a white background.

3. Edit the text. Using the keystroke **CTRL+Enter** creates a new line.

4. Pressing **Enter** updates the label to the entered text.

Deleting a Border

Deleting a border removes it from all stitches and removes its entry from the key. To delete a border;- 

1. Select the border entry in the key (see Selection Tools).

2. On the main menu bar, select either **Edit > Cut** or **Edit > Delete**.

Alternatively use the keystrokes **CTRL+X** (on Windows) or **CMD+X** (on Mac) or select the Cut / Delete Icons from the toolbar.
Chapter 7. Validating charts

Validating charts

About validating

When designing a chart it can be very useful to quickly check if it is 'valid', that is, if the number of stitches that are produced by each row matches the number needed to work the following row. The Knitting Chart Editor does this checking or 'validation' for you every time that a chart is edited. If finds a discrepancy then this is displayed in the Outline View. Note that the display in the Outline View can be toggled between an Overview and an expandable Outline. To see the expandable Outline, select the Outline icon on the Outline View toolbar. To see the Overview, select the Overview icon on the Outline View toolbar.

What exactly is checked?

All stitches have values for 'consumes' and 'produces'. The 'consumes' value is the number of stitches that need to be on the needle in order to work the stitch. The 'produces' value is the number of stitches that will be on the needle after this stitch is worked. To view these values for a stitch or number of stitches see Viewing and editing stitch libraries.

For each row, the Knitting Chart Editor calculates the number of stitches on the needles after the chart row is worked taking into account any explicit repeats that have been defined. This gives the total number of stitches 'produced' by that row and is the same as the stitch count that is optionally included in the written instruction output.

Also for each row, the Knitting Chart Editor calculates the number of stitches that need to be on the needles in order for the chart row to be worked. As before this takes into account any explicit repeats that have been defined. The result is the total number of stitches 'consumed' by that row.

Then, for each row, if the number of stitches 'produced' does not match the number of stitches 'consumed' by the following row, both chart rows are marked as having an error. It is possible that only one of the rows will have an actual error caused by too few or many increases / decreases or perhaps an incorrect decrease or increase has been used. However, the Knitting Chart Editor has no way of knowing exactly where the discrepancy lies so both rows are marked as in error. In addition, if any chart contains rows that have an error, the chart is also marked as being in error.

If wrong side rows are hidden on a chart, then wrong side rows will usually (see below) also be excluded from the written output and the expandable Outline. In this case, wrong side rows will be ignored when validating the chart and it will be only the 'consumes' and 'produces' values for right side rows that will be compared.

If wrong side rows are hidden on a chart and you still want the wrong side rows to be included in the generated written output and used for validating, then create a user Written stylesheet. See Creating a user stylesheet. Edit the stylesheet to unselect Ignore hidden rows. After you have created and edited the user Written stylesheet set it as the current Written stylesheet for the chart diagram file. See Setting a stylesheet as the 'active' stylesheet.

Viewing the validation results

To view the validation results:
Validating charts

1. The validation results are displayed in the Outline View when the view is toggled to display the expandable Outline.

If the expandable Outline is not currently visible select the Outline icon on the Outline View toolbar (circled in orange in the screenshot below).

2. Initially the Outline is in a 'collapsed' state and only the chart title(s) (if any) will be displayed.

To view more detail, click on the right pointing triangle on the left hand side (circled in orange in the screenshot below).

3. All of the rows in that chart will now be displayed together with information about the total 'consumes' and 'produces' values for each row.
4. To view more detail for each row, click on the right pointing triangle on the left hand side of the row label.

5. All of the stitches and repeats in that row will now be displayed.

If an explicit repeat has been defined, the repeat will be displayed along with details of the number of stitches both consumed and produced by that repeat.

To view more detail for a repeat, click on the right pointing triangle on it's left hand side.

6. If the Knitting Chart Editor has found a discrepancy between the total number of stitches that a row produces and the total number of stitches that the following row consumes, then a red error marker is displayed next to each of the rows as well as against the chart.
7. The information displayed can be used to check the chart to find and fix the cause of the error. The Knitting Chart Editor validates the chart after each edit so, as soon as it is fixed, the red error markers are removed.
Chapter 8. Working with Text Input

Working with Text Input

Written instructions can be used as input to create a chart. The written instructions are parsed by the software as they are typed in and feedback on errors given if it does not understand something that is entered. Content assist is available. Note that Mosaic charts are not currently supported with this feature.

Creating a New Written Instructions text file.

To create a new text file containing Written Instructions:

1. On the main menu bar, select **File > New > New Written Instructions**. The New Written Instructions dialog opens.

2. The folder defaults to the home directory. To select a different directory use the Browse button.

3. The file name contains a generated default name. If desired, type in a different file name. The file extension must be ".txt".

4. (Optional) Type in a chart title. This can be edited later.

5. Select **Finish**.

The New Written Instructions dialog can also be opened by selecting the New Written Instructions Icon from the main toolbar.

Editing the Written Instructions.

A new Written Instructions file has a single row with the **Chart** keyword and the title if one was entered in the dialog.
Text can now be entered. Because it is to be understood by the software, certain conventions need to be followed. Instructions are entered for either rows or rounds. The syntax is probably best illustrated with some examples:

Row 1 (RS) : k2, p2.
Row 1 : k2, p2.
Row 4 (WS) : k2, p2.
Round 1 : k2, p2.

When using the written instructions to initialize the New Chart Diagram from Written Instructions dialog (see below), the Knitting Chart Editor checks the first instruction in the chart. If it is a row, then flat knitting is assumed, otherwise circular knitting. Likewise the row / round number of the first instruction is used in the dialog. All other row numbers are ignored and rows are numbered sequentially. For flat knitting, the (RS) and (WS) keywords can be used to indicate that the first instruction starts on a Right Side or Wrong Side row. If neither (RS) or (WS) are used on the first Row then it is assumed that the first row is a right side row. (RS) / (WS) keywords on all other instructions are ignored.

Stitches are entered in order with commas separating them and a full stop at the end. The Knitting Chart Editor matches the text entered against either the name or abbreviation of stitches in the stitch library. If existing stitches have been customised so that the name or abbreviation has been changed, then it will be the updated name or abbreviation that will be used. If new custom stitches have been added, then these can also be used. Here are some examples:

Row 1 : yo, slip, sl.
Row 1 : 2/2 RC, kfb, sl.

If you enter a stitch that is not recognised, a red 'squiggle' is placed under the unrecognised text. An error marker is placed in the margin for all rows with errors. If you move the cursor over either of the error markers an error message is displayed.
If you cannot remember the name or abbreviation of a stitch, then the Content Assist feature can help. Make sure that the editing cursor (usually a vertical bar) is placed where you want to enter text. Then use the keystroke **Control+space** to invoke Content Assist. A popup menu will appear giving you a list of valid options for the exact position where you are entering text.

If you can remember the beginning characters of a stitch name, then enter those first before invoking Content Assist. Then the list will be filtered so that it only contains stitches beginning with those characters.

Knit and purl stitches have properties that are not shared with other stitches. When there are several consecutive knit or purl stitches, they can be condensed:

Row 1 : k2, p2.

A single knit or purl stitch can be written in a number of different ways:

Round 1 : k, knit, k1, k 1, knit 1, p, p1, p 1, purl, purl 1.

Note that 'k' means 'knit 1 stitch' and is equivalent to 'k1' except when it is the only stitch in the row. This also holds for 'p'.

If a row contains only knit or purl stitches, then it can be abbreviated to 'k' and the Knitting Chart Editor will treat this instruction as an implicit 'knit all stitches in row' instruction. It will then calculate how many stitches will be in that row and assign the number of knit stitches accordingly. For example:
Row 1 : k2tog, yo, k1, yo, ssk.

Row 2 : k.

Row 1 finishes with 5 stitches. Hence the 'k' instruction of Row 2 really means k5.

The Outline view gives immediate feedback on how the Knitting Chart Editor has understood the text entered. For each row it calculates how many columns will be needed in a chart to display the instructions in that row. In addition it calculates how many stitches are needed on the needles to knit that row and how many stitches will remain on the needles after that row has been worked. These are displayed as the 'consumes' and 'produces' values respectively:

```
Outline
├── Row 1: 4 columns, consumes 4, produces 4
│   └── Row 2: 4 columns, consumes 4, produces 4

Select on the arrows to open / close the outline elements.
```

The Outline View consists of elements nested inside each other. If you cannot see all of the rows or stitches that you are expecting to see, click on the arrows at the end of the lines in the Outline View to open the display.

Repeats can also be entered. There are two categories of repeats; Explicit repeats and Implicit repeats and these are treated differently when entered as written instructions. See Working with Borders and Repeats for more information about the definitions of these repeats.

There are two types of explicit repeats; 'Asterisks' and 'Round Brackets'. Explicit repeats are not expanded when converting from written instructions to chart. The calculations for how many stitches a row 'consumes' and 'produces' does take into account the number of times that a repeat is worked.

There is just one type of Implicit Repeat; 'Square Brackets'. Implicit repeats are always expanded when converting from written instructions to chart and provide a shortcut when entering stitches that repeat across a chart.

**Creating a Chart from Written Instructions.**

To create a new Chart Diagram file from Written Instructions:

1. On the main menu bar, select File > New > New Chart Diagram from Written Instructions. The New Chart Diagram from Written Instructions dialog opens.
2. The folder defaults to the directory containing the written instructions text file. To select a different directory use the Browse button.

3. The file name contains a generated default name. If desired, type in a different file name. The file extension must be ".knit".

4. (Optional) Type in a chart title. This can be edited later.

5. The number of rows and columns are determined by the written instructions and cannot be changed in this dialog. Once the chart has been created, rows and columns can be inserted or deleted.

6. (Optional) Edit the starting row and column numbers and other properties such as circular or flat knitting etc. The values in the dialog are initialized from the written instructions but can be edited in the dialog. They can also be edited once the chart is created.

7. Select Finish.

The New Chart Diagram from Written Instructions dialog can also be opened by selecting the New Chart Diagram from Written Instructions Icon from the main toolbar.
Chapter 9. Exporting Chart Image and Written Instructions

Exporting Chart Images.

The Chart Diagram file can be exported for use in other programs or for sharing with others. The following formats are possible:- Scalable Vector Graphics (SVG), Portable Data Format (PDF) as well as various bitmap formats such as PNG, JPG, GIF and BMP. SVG is the recommended format as the vector graphics means that the image is sharp at any zoom level. SVG images can easily be imported into LibreOffice and Scribus and, with a plugin, into OpenOffice. PDF is the best format to use for sharing quickly with others.

To export the charts and key as an image:-

1. (Optional) Select the chart(s) / key whose images will be created (see Selection Tools). Choose this option if you wish to have either an image of the chart without the key or an image of the key. If no selection is made then the image will contain both the chart and the key.

2. On the main menu bar, select **Diagram > Export to Image**. Alternatively select the Export to Image icon from the main tool bar. The Export to Image wizard opens.

![Export to Image wizard](image.png)

3. Change dialog values as desired.

4. Select **OK**.

To export the key entries as individual images:-

1. (Optional) Select the key (see Selection Tools).

2. On the main menu bar, select **Diagram > Export to Image**. Alternatively select the Export to Image icon from the main tool bar. The Export to Image wizard opens.
3. Check the 'Export key entries as individual files' box.

4. Change other dialog values as desired.

5. Select OK.

Exporting Chart Written Instructions

The written instructions for the charts can also be exported for use in other programs or for sharing with others. At present the only format possible is plain text (TXT).

To export the written instructions:

1. On the main menu bar, select Diagram > Export to Text. Alternatively select the Export to Text icon from the main tool bar. The Export to Text wizard opens.

2. Change dialog values as desired.

3. Select OK.
Chapter 10. Setting Preferences

Setting Preferences

Many of the default settings and behaviours of the software can be changed by using the Preferences feature.

To set the preferences:

1. On Windows and Linux systems, from the main menu bar, select **Tools > Preferences**.

   On Mac OS X systems, from the main menu bar, select **Knitting Chart Editor > Preferences**. The Preferences dialog opens.

2. To change settings related specifically to the Knitting Chart Editor select **Knitting Chart Editor**.

3. To view and edit Stitch libraries select **Stitch Libraries**. To see more detailed information about using the preferences to edit stitch libraries see Viewing and editing stitch libraries.

4. To view and edit Stylesheets select **Stylesheets**. To see more detailed information about using the preferences to edit stylesheets see Viewing and editing stylesheets.

5. Make changes as appropriate.

6. To see more preference pages click on the icon on the left of 'Knitting Chart Editor'. This is circled in red in the screenshot below.
7. Select **OK**.
Chapter 11. Updating the StitchMastery Knitting Chart Editor

Updating the StitchMastery Knitting Chart Editor

The software can be updated by a simple command rather than having to uninstall and reinstall a new version. Commands are also available to check the current level of software as well as details about the configuration and the error log. This can be very useful when a problem occurs. An internet connection is required to install updates.

Installing Updates

To install updates:-

1. On the main menu bar, select **Tools > Install Updates**.

2. The software checks if updates are available.

3. The Available Updates dialog opens.

4. Select the latest update and select **Next**. The next page of the dialog opens. Select **Finish**.

5. You will then be prompted to agree to the StitchMastery Knitting Chart Editor licence agreement. Not agreeing will cancel the update process.

6. The Security Warning dialog opens. Select **OK** to proceed.

7. The software will then download and install the updates. This may take a few minutes. When it is complete the Software Updates dialog opens to recommend that you restart the software. Select **Yes**.

8. The software will restart automatically.

To check the version level, installation history and logging and configuration information;-

1. On Windows and Linux systems, from the main menu bar, select **Tools > About Knitting Chart Editor**.

   On Mac OS X systems, from the main menu bar, select **Knitting Chart Editor > About Knitting Chart Editor**.

   The About Knitting Chart Editor dialog opens.

2. Select **Installation Details**. The Knitting Chart Editor Installation Details dialog opens.

3. Select the 'Installed Software' tab to see the currently installed version of the software.

4. Select the 'Configuration' tab to see the configuration details of your software. This information can be particularly useful to StitchMastery when analysing problems with the software.

5. Select **Copy to Clipboard** to copy the complete page to the system clipboard in order to be able to paste it into a text file or email to send to StitchMastery.
6. Select **View Error Log** to be able to view the software error log. The Open With dialog opens to display a list of possible software that can be used to open the log file. As with the configuration information, the log file is very useful to analyse problems that may occur.

7. Select WordPad on a Windows system or TextEdit on a Mac. Make a copy of the log file to send to StitchMastery at support@stitchmastery.com.